summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-08-24 19:04:50 +0100
committerMatthew Smith <matthew@gentoo.org>2022-08-24 19:05:33 +0100
commit07c1d5299fa6d64c9c220a49b05bc63dc0c44a83 (patch)
tree5ab0d3ada15966f7fa1aad72e31b0731ee17efff
parentdev-embedded/libjaylink: update LICENSE (diff)
downloadgentoo-07c1d529.tar.gz
gentoo-07c1d529.tar.bz2
gentoo-07c1d529.zip
dev-embedded/libjaylink: add 0.3.0
Also bump to EAPI-8, drop static-libs, drop multilib, and install the udev rules. Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--dev-embedded/libjaylink/Manifest1
-rw-r--r--dev-embedded/libjaylink/libjaylink-0.3.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-embedded/libjaylink/Manifest b/dev-embedded/libjaylink/Manifest
index a0c87c1b1243..02afd9e8d19c 100644
--- a/dev-embedded/libjaylink/Manifest
+++ b/dev-embedded/libjaylink/Manifest
@@ -1 +1,2 @@
DIST libjaylink-0.2.0.tar.bz2 59078 BLAKE2B 7928875248972bc00ec46511861e160491f7a53f729e0fbfe3a6d08335532fffc9e285e8a354a390037bebe696b6740bdc422164238947baf5e0fcf8f55c0dd5 SHA512 5a8c458982fdea2025aa3ce774d41cc58a283824dcd90a94531ee5e6ca50d9961b0ebb40a6dd3a97fdfcb44625437d685151560185449c3161fe399e0651da44
+DIST libjaylink-0.3.0.tar.bz2 61075 BLAKE2B 84946fbe0a061117f92b8011c0b5eeb30f8f74817128a5fd6a6d519c7a0f07f447d87d0fe72d7a47d17ab2fa33cdc3820e0c556f75c5dedad30faf5e6cf5739d SHA512 714de9297fb59eccee7eb461f37b20459991bffd31aac8eb20014f00716bb94ff4cda96a3d1746419c7722b6b7d97e7a42df9fb3b5c4f83a3f1ac79647159426
diff --git a/dev-embedded/libjaylink/libjaylink-0.3.0.ebuild b/dev-embedded/libjaylink/libjaylink-0.3.0.ebuild
new file mode 100644
index 000000000000..8601f4cec5f0
--- /dev/null
+++ b/dev-embedded/libjaylink/libjaylink-0.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools udev
+
+DESCRIPTION="Library to access J-Link devices"
+HOMEPAGE="https://gitlab.zapb.de/libjaylink/libjaylink"
+SRC_URI="https://gitlab.zapb.de/libjaylink/libjaylink/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Remove -Werror from CFLAGS.
+ sed -i '/^JAYLINK_CFLAGS=/s/ -Werror//' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ udev_dorules contrib/99-${PN}.rules
+ find "${D}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}