summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-13 11:27:16 +0000
committerSam James <sam@gentoo.org>2021-03-13 15:23:29 +0000
commit07da955dd583946e61a0f40f962f251c03ca70e9 (patch)
tree8c17b0230d348886de454fecb87f6a05af952bff
parentdev-ml/ocaml-gettext: convert to dev-ml/ounit2 for tests (diff)
downloadgentoo-07da955dd583946e61a0f40f962f251c03ca70e9.tar.gz
gentoo-07da955dd583946e61a0f40f962f251c03ca70e9.tar.bz2
gentoo-07da955dd583946e61a0f40f962f251c03ca70e9.zip
dev-ml/ocaml-gettext: convert to dev-ml/ounit2 for tests
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild b/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild
index 62186a50ccd8..640af1cd5c11 100644
--- a/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild
+++ b/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild
@@ -28,9 +28,16 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
- test? ( dev-ml/ounit[ocamlopt=] )
+ test? ( dev-ml/ounit2[ocamlopt=] )
"
+src_prepare() {
+ default
+
+ # Port to dev-ml/ounit2
+ sed -i -e 's/oUnit/ounit2/' test/{,common,test-camomile,test-stub}/dune || die
+}
+
src_install() {
dune_src_install
}