summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-10-05 13:48:53 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-10-05 13:49:17 -0500
commit07e00db91846df066e1dc3e122fe0bae104fcfc0 (patch)
tree62ee0219c8d84fcdcb9fda0f4f1416ccfe8772f0
parentsys-apps/rng-tools: add support for libressl (diff)
downloadgentoo-07e00db9.tar.gz
gentoo-07e00db9.tar.bz2
gentoo-07e00db9.zip
app-metrics/prometheus: 2.21.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-metrics/prometheus/Manifest2
-rw-r--r--app-metrics/prometheus/prometheus-2.21.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index 517cf63cccd0..1e81f4793065 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -1,3 +1,5 @@
DIST prometheus-2.13.1.tar.gz 15249891 BLAKE2B 35cd3c81bdb4f3a783c2ab1f1318946db5b25c94496fe351739a59259a726bf54d418d6b29efeff44c8007353ed63368819ce89ffe6a4f380b7ae216da3c4d63 SHA512 aed3b44db97cd2a67add64d13e950246b25c2b459f6b1081a6c548862c4e85c055254a0dfb94b08ac85f83dbbe30afceb1c54a8ad6f7ff1367aeb6af6d270e8a
DIST prometheus-2.19.1-assets.tar.gz 5032055 BLAKE2B 75bc247d3dfbcccf3a9d7ef8a23fabe2d92d698670f5aabb19e1ee019e0197aa4fd49cfd53353e09a765a014af70ad860c7d1b6bce292632e5ed1175dd206ae9 SHA512 52d1f80d9ab2de778e8a0c81549ff83647d3d8af37ccf535a6fc4ac45fe29f25f6592e9b5eb137cd5ed6f6730835e4ba52b6c4c82e5b0bb2336b90c809d756de
DIST prometheus-2.19.1.tar.gz 13343138 BLAKE2B 042f2c6e10e3d7f50b2373d9c3977db0318c8c9839e313463890ccae58c91d6d46c306d5aaeb795fb1a9649477b179999cb6b182aca9dee222d8fba557bf6d74 SHA512 a54a83b21ac8f3477e678ca365b8f04adcbe5cdd8a17d842eb9cd2e3428238841fb0492da6f4ec973f48803b0739667c734ae8a88b48d12555e23410e6461629
+DIST prometheus-2.21.0-assets.tar.gz 5060038 BLAKE2B 10c9a89be71935072e6096c1bd62d9e3ff015b98baa4d11eb19cc938c857d38ebd22345173a9e404441bc1dceda4f86e82d455e6f4ea23d6ef5c78cba130ce9d SHA512 0f4b03b33c04a86d44c6521d4f0a1048f69d32b0e1797b5508a279d990171ca15268b461f567146f689aeda9fc696fd8a656147b20b6fd0293542fa15fd35a29
+DIST prometheus-2.21.0.tar.gz 13971178 BLAKE2B 8701d8c4318b6624e448b91959ea5afd62d0574f4329bc72c141145b197c653912b050f2da93d670ad350a244eb18c0a7e8ea9c12083fcb885233d8631653447 SHA512 6c4af981582a0cb07a8be5cfa786797507f3f23e4d52f03a4f4126b9b5df84f0481d7400120ed3368268f77d07d8d939f1a8758044e65ede291d9ccafc1b3239
diff --git a/app-metrics/prometheus/prometheus-2.21.0.ebuild b/app-metrics/prometheus/prometheus-2.21.0.ebuild
new file mode 100644
index 000000000000..b4bb7a694d13
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.21.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+MY_PV=v${PV/_rc/-rc.}
+GIT_COMMIT=e83ef207b
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="https://github.com/prometheus/prometheus/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~williamh/dist/${P}-assets.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+COMMON_DEPEND="acct-group/prometheus
+ acct-user/prometheus"
+DEPEND="!app-metrics/prometheus-bin
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND=">=dev-util/promu-0.3.0"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${GIT_COMMIT}/" .promu.yml || die
+ mv ../assets_vfsdata.go web/ui || die
+}
+
+src_compile() {
+ promu build --prefix bin -v || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}