summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-21 08:51:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-21 08:51:49 +0100
commit0801d8cfe6fa68a0e411069ea54fcd77e67fa351 (patch)
tree0bc1f76175844aaddef9e6ab4aa0b3451b85454c
parentdev-python/boto3: Remove old (diff)
downloadgentoo-0801d8cfe6fa68a0e411069ea54fcd77e67fa351.tar.gz
gentoo-0801d8cfe6fa68a0e411069ea54fcd77e67fa351.tar.bz2
gentoo-0801d8cfe6fa68a0e411069ea54fcd77e67fa351.zip
dev-python/botocore: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.59.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 502cf899a7ed..c6735247a231 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,4 +1,3 @@
-DIST botocore-1.29.59.gh.tar.gz 11131182 BLAKE2B fa85e1f8dc3c366f7a7fb3e9b06dd298b1ad62be882891df3414289aa9e88bff72753690a1438e6040aefb7cafa1718a70c940e8cd2b4e743df44013b5748ef6 SHA512 9a4811b44c67652cacc899d1d84d4db1305cb60e73dd47d7f543b85ec37f921cab00a51d67b48ab6a215be8f7543e30c54585e0fb337085e1b75774b053c4bf3
DIST botocore-1.29.69.gh.tar.gz 11140109 BLAKE2B 5a91e6d425f4a5f424f95fd9bcd893c06fd42eb2a34ae870a76f0a28ee59771a8e1759a8afa959592a0ae7537229d791805539125890d17d3f4a33bb0618e76d SHA512 30d538591b25aae82e93352f4eda2d76eda6d02604cdbe822cd5f7559cfa268e2245b5cfb8ba6875e5e3a35cad2bef7210bbe03276236871441515cdf6ff2ece
DIST botocore-1.29.74.gh.tar.gz 11153254 BLAKE2B b3d3b75643cd5e3fac54a09e971daa23a043ba9f7ab773c2fd57dc15417c1b30c6f503515bad8734332bc40c4210e4ac09566c0742649c6ac3592e81ae9f8d79 SHA512 944ebbf1268fa9e8bb68ce5960da347613bcab585bf54c2fd6dbecb499088c1dc426357cde0a0f0d1780ecbc06acc33d8587f37c7f3d13577283b4549a353406
DIST botocore-1.29.75.gh.tar.gz 11152953 BLAKE2B 69c9c520f1caa97d931bc535261e14fb07ca1cd8ae5ba8edcb25eceb97c2dc367bf93de7aa19f87c042c69ece36a87efddb5b7495790ab5d6c6ca48bc99f7d2d SHA512 9778771373b675f6d6f0df04311b3b9bc53268a4628e0cb88737e70346a3a18efdca3a6d3325e2b99bcf0054d5486000fb28d3ed64cad181f8df80d2a692f24b
diff --git a/dev-python/botocore/botocore-1.29.59.ebuild b/dev-python/botocore/botocore-1.29.59.ebuild
deleted file mode 100644
index 5afa7a9459c5..000000000000
--- a/dev-python/botocore/botocore-1.29.59.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Low-level, data-driven core of boto 3"
-HOMEPAGE="
- https://github.com/boto/botocore/
- https://pypi.org/project/botocore/
-"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/botocore"
- inherit git-r3
-else
- SRC_URI="
- https://github.com/boto/botocore/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- "
- KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- <dev-python/jmespath-2[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin deps
- sed -i -e "s:>=.*':':" setup.py || die
-
- # unbundle deps
- rm -r botocore/vendored || die
- find -name '*.py' -exec sed -i \
- -e 's:from botocore[.]vendored import:import:' \
- -e 's:from botocore[.]vendored[.]:from :' \
- {} + || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # rely on bundled six
- tests/functional/test_six_imports.py::test_no_bare_six_imports
- tests/functional/test_six_threading.py::test_six_thread_safety
- # fails on unrelated warnings
- tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
- tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
- # TODO
- tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
- )
-
- epytest tests/{functional,unit} -n "$(makeopts_jobs)"
-}