summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-06 22:45:02 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-06 22:54:40 +0200
commit08024617c343707bab3517d47cc55b7f23960e52 (patch)
treeb5afd2544f5d4754814f72655b9786357659c51e
parentnet-misc/ices: fix build with clang/lld and upcoming clang-16 (diff)
downloadgentoo-08024617.tar.gz
gentoo-08024617.tar.bz2
gentoo-08024617.zip
dev-lang/boogie: fix broken NUGET_PACKAGES variable
Also use "--source" flag for running "dotnet restore" which will warn when NUGET_PACKAGES directory does not exist. Closes: https://bugs.gentoo.org/875755 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/boogie/boogie-2.15.8-r3.ebuild (renamed from dev-lang/boogie/boogie-2.15.8-r2.ebuild)5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-lang/boogie/boogie-2.15.8-r2.ebuild b/dev-lang/boogie/boogie-2.15.8-r3.ebuild
index 7324430f8146..1b6c0b18edd5 100644
--- a/dev-lang/boogie/boogie-2.15.8-r2.ebuild
+++ b/dev-lang/boogie/boogie-2.15.8-r3.ebuild
@@ -43,7 +43,7 @@ src_prepare() {
export DOTNET_NOLOGO=1
export DOTNET_CONFIGURATION=$(usex debug Debug Release)
export DOTNET_OUTPUT="${WORKDIR}"/${P}_net${DOTNET_COMPAT}_${DOTNET_CONFIGURATION}/${PN}
- export NUGET_PACKAGES="${S}"/nuget_packages
+ export NUGET_PACKAGES="${S}"/Source/nuget_packages
default
@@ -68,7 +68,8 @@ src_prepare() {
}
src_configure() {
- edob dotnet restore -p:TargetFramework=net${DOTNET_COMPAT} "${S}"/Source
+ edob dotnet restore "${S}"/Source \
+ --source "${NUGET_PACKAGES}" -p:TargetFramework=net${DOTNET_COMPAT}
}
src_compile() {