summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-29 04:52:00 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-29 04:53:39 +0200
commit08142955631185a94d3f096a20732214af7a8811 (patch)
tree8b2b56e150985fd8bf9058e98ba66a8bab438768
parentRename dev-python/{mdx_gh_links → mdx-gh-links} (diff)
downloadgentoo-08142955631185a94d3f096a20732214af7a8811.tar.gz
gentoo-08142955631185a94d3f096a20732214af7a8811.tar.bz2
gentoo-08142955631185a94d3f096a20732214af7a8811.zip
dev-python/mdx-gh-links: Bump to 0.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mdx-gh-links/Manifest1
-rw-r--r--dev-python/mdx-gh-links/mdx-gh-links-0.3.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/mdx-gh-links/Manifest b/dev-python/mdx-gh-links/Manifest
index b6cd9505d8f5..e42625fd0912 100644
--- a/dev-python/mdx-gh-links/Manifest
+++ b/dev-python/mdx-gh-links/Manifest
@@ -1 +1,2 @@
+DIST github-links-0.3.1.gh.tar.gz 7004 BLAKE2B fbb84d75ee1976f7a160e7b561413d0e2721158b812d395c5b78c8b2dfc7600561a082f9caa32fd2a1d0fec86674555258f71abaede0e539f519f1656f416e0d SHA512 3d201b00fcef7185c616534bbd16c0ce54aacf368a76c6e44328579b270ff4f34803b8c69dec958266407608b2bc3f6e8d141f803961ca65b48257d5c460c403
DIST github-links-0.3.gh.tar.gz 6756 BLAKE2B 6b9f7e86d2ec96a6b1b9fd21f20f1964e5fbf4b3ebb33bcd6dccd2e8b811acff7e39606acbf8f48a602afb21733dbd6375e2d1ef30a2a551547fbf9582b525c6 SHA512 8f738298d8a1512e2757a3a7fed091e3a90d59b20b3d03f1a75e087b30b9f9d4876d46ced04994f98a4454a9bf4ebabc305ebf28b4441eb93e5df87822c35459
diff --git a/dev-python/mdx-gh-links/mdx-gh-links-0.3.1.ebuild b/dev-python/mdx-gh-links/mdx-gh-links-0.3.1.ebuild
new file mode 100644
index 000000000000..5ae8fe2aad41
--- /dev/null
+++ b/dev-python/mdx-gh-links/mdx-gh-links-0.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_P=github-links-${PV}
+DESCRIPTION="An extension which adds links to GitHub users, repositories, issues and commits"
+HOMEPAGE="
+ https://github.com/Python-Markdown/github-links/
+ https://pypi.org/project/mdx-gh-links/
+"
+SRC_URI="
+ https://github.com/Python-Markdown/github-links/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/markdown-3.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest