summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-09-29 11:07:03 +0100
committerMatthew Smith <matthew@gentoo.org>2023-09-29 11:07:03 +0100
commit081863ab2a7f665ce2806288b9bfa83ac9e2f0e9 (patch)
tree3ae346ddd7fbb89bbee8ddbf7ff9cbab2ee61aef
parentnet-mail/mu: drop 1.10.3, 1.10.4 (diff)
downloadgentoo-081863ab2a7f665ce2806288b9bfa83ac9e2f0e9.tar.gz
gentoo-081863ab2a7f665ce2806288b9bfa83ac9e2f0e9.tar.bz2
gentoo-081863ab2a7f665ce2806288b9bfa83ac9e2f0e9.zip
net-mail/mu: add 1.10.7
Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.10.7.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index f163ba33b196..bf9c691cba01 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1 +1,2 @@
DIST mu-1.10.6.tar.xz 570660 BLAKE2B 96816753a3b38392e7e943d8b72fd98b44d201c022b6018eb692cf594bd9f7285a84d00da53ab85a671d5375b7eafb9eb5a0e1fff51ad5a9b2d035fa1c0f8d23 SHA512 78eb5e21ac2dc2a6665a257593781c3b9a390644f78945ce9eef18acab6ca750b16773de2665a1ced9b2f9434b4a2879d07bc586b3abdb82ccc0cd3b59ab51e5
+DIST mu-1.10.7.tar.xz 570740 BLAKE2B fcc1d3f6f293e2161e5bcef85eb085a3af95ff8d410e074f6a015f68e914592da171c357c795dad9d48ac8438e46f261b4f1be54d8f2e8075f93d72bd5a9a483 SHA512 0b588bb54ac79d23920150dbee7f7f7ca606d0fc8e169b2ca64a7cf0d062bb5c399c522d68f9bf6c3624addb8d9342efe0f45309d422eac3e3f8948acfebd904
diff --git a/net-mail/mu/mu-1.10.7.ebuild b/net-mail/mu/mu-1.10.7.ebuild
new file mode 100644
index 000000000000..2acec2e5ddb5
--- /dev/null
+++ b/net-mail/mu/mu-1.10.7.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common meson
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~x64-macos"
+IUSE="emacs readline"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-25.3:* )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-apps/texinfo
+ virtual/pkgconfig
+"
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_prepare() {
+ default
+
+ # Don't install NEWS.org into /usr/share/doc.
+ sed -i '/NEWS.org/,+1 d' meson.build || die
+ sed -i '/mu4e-about.org/d' mu4e/meson.build || die
+
+ # Don't compress the info file.
+ sed -i '/gzip/d' build-aux/meson-install-info.sh || die
+
+ # Instead, put it in /usr/share/doc/${PF}.
+ sed -i "/MU_DOC_DIR/s/mu/${PF}/" mu4e/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature readline)
+ -Demacs="$(usex emacs "${EMACS}" emacs-not-enabled)"
+ # TODO: revisit this, it's not actually deprecated, just been reworked
+ -Dguile=disabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Since meson no longer installs NEWS.org, install it with dodoc.
+ # Also, it must be uncompressed so that it can be viewed with
+ # mu4e-info.
+ docompress -x /usr/share/doc/${PF}/NEWS.org
+ dodoc NEWS.org
+
+ # Same as above.
+ docompress -x /usr/share/doc/${PF}/mu4e-about.org
+ dodoc mu4e/mu4e-about.org
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}