summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-10-29 14:25:03 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-10-29 14:32:25 +0100
commit081d1e7195980d3276bc13479387a0bbf748a91b (patch)
tree70fc64165e6cbbf71924395b09a74857b29cf90f
parentgames-arcade/epiar: depend on deprecated lua APIs (diff)
downloadgentoo-081d1e7195980d3276bc13479387a0bbf748a91b.tar.gz
gentoo-081d1e7195980d3276bc13479387a0bbf748a91b.tar.bz2
gentoo-081d1e7195980d3276bc13479387a0bbf748a91b.zip
dev-util/patchelf: Version bump to 0.16.1
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--dev-util/patchelf/Manifest1
-rw-r--r--dev-util/patchelf/patchelf-0.16.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/patchelf/Manifest b/dev-util/patchelf/Manifest
index 6709bd2b29ca..b8e82e1204a7 100644
--- a/dev-util/patchelf/Manifest
+++ b/dev-util/patchelf/Manifest
@@ -1,2 +1,3 @@
DIST patchelf-0.14.5.tar.gz 124767 BLAKE2B f2e02fb468db7c8c0c4270c7f95ea6c8dc6ffab7ddb0a6479bd5d1dd0481cbc55982af21a13f42076504417264a11e74d50a9f15d3d5735e47019001abf33e41 SHA512 1b7eca84f6fe2d6f6d4469ca1ccdf35dc920d2052ba94b7daeba6c8cb41fdaff20b1e5bac7c8a7650ff12bf4156da87f84d32e75b09958636dc992a1b7b1a59d
DIST patchelf-0.15.0.tar.gz 125803 BLAKE2B 08fc2cffd7d9e835c01c828c16762fb0b3c3e422990f2d0028a65a3e0ec849d01bdef699b6f68afa6bf307e34f5e76121fc94460793c95c055552e1d8a68d772 SHA512 3b2d3d6458be5b2d43cd2878dfb1a185a95cc13cd4c94abd0ee79979afb36f46e347acc292b8d9c2954a342b7291774e6a1b63930e9f90a1cf4179ec075ab046
+DIST patchelf-0.16.1.tar.gz 132450 BLAKE2B 047fe9900eff3a4fef19550b49ea3c53dc8fc77c1d110888af39362dce745c3568e493f91d96cd35d73291da8e0cf4f10121162f4e8a32d43a3c014716477a4c SHA512 62475b942ff07c2eb225760d69eab99af4e9aa14ca51aeb3b7d53a6a1943b02acffc1b2059d985a921f5af7bbaf40a096b8cdf592979260e1e2602db02e7f247
diff --git a/dev-util/patchelf/patchelf-0.16.1.ebuild b/dev-util/patchelf/patchelf-0.16.1.ebuild
new file mode 100644
index 000000000000..45b8be95445b
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.16.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="https://github.com/NixOS/patchelf"
+SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~riscv-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+
+ eautoreconf
+}