summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-29 07:32:36 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-29 07:49:19 +0200
commit0829ad7f80ba3ced92a9a027c3c528d4ecd92e36 (patch)
treec3ab430c542cb59aa9536ab8d901398a73f88f3a
parentdev-python/precis-i18n: Enable py3.12 (diff)
downloadgentoo-0829ad7f80ba3ced92a9a027c3c528d4ecd92e36.tar.gz
gentoo-0829ad7f80ba3ced92a9a027c3c528d4ecd92e36.tar.bz2
gentoo-0829ad7f80ba3ced92a9a027c3c528d4ecd92e36.zip
dev-python/pip-run: Bump to 10.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pip-run/Manifest1
-rw-r--r--dev-python/pip-run/pip-run-10.2.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index 90ff1b0efb2e..47a59d6061e1 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -1,2 +1,3 @@
DIST pip-run-10.0.7.tar.gz 32869 BLAKE2B ea5dfea09def536eced9436a114f12cbefccf26c4b37376a560dc1fffdd8167d019ec52d57666d7b4d77dc9c580a5f48455d945aa9ddb4340a7dca88f0ded309 SHA512 cd8780372f579005e40c77b3c2d9e582cd1a144e871eec205fd0bd2ff64eac837918211d3479088f56bd3043dbfd883502b2d6f7b01dc24448888f65fdd6920b
DIST pip-run-10.1.1.tar.gz 33010 BLAKE2B 5a3dcd1e119b65718b465ecbd118d80de776252ecbd438344eb78abc2e4a69073417310ed096f0b604740762aa24af2788041476c93d919ea72812e1597327f5 SHA512 ddf61aa31012567ff21e943739a1e29066875db3c39ca77abfa409fd75abc599756ca8aeaf9bd23d19af46ad2747e7dec4a7d3cf76a444f59c19e769419dc59a
+DIST pip-run-10.2.0.tar.gz 33523 BLAKE2B 7d19c089da98dbba2faec969f490fcd5ea48881f4ccbbfaa283465ef083521aee7d82b9de8b03a89ec8b08005db1232cd9577030cb98c111b4a0e0f7294cca84 SHA512 b26a00c6ebd8e9e505e6b218fea7070b23b5926de44e1d5a762abb2a4ebd62b1bdda7e19c4092012daf068b518a2e127ab08099f6d1a7ddc643b3ba5bf999ed0
diff --git a/dev-python/pip-run/pip-run-10.2.0.ebuild b/dev-python/pip-run/pip-run-10.2.0.ebuild
new file mode 100644
index 000000000000..36f03616bed3
--- /dev/null
+++ b/dev-python/pip-run/pip-run-10.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="
+ https://github.com/jaraco/pip-run/
+ https://pypi.org/project/pip-run/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib-resources[${PYTHON_USEDEP}]
+ ' 3.8)
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-test-5.3[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=()
+
+ if ! has_version "dev-python/nbformat[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_scripts.py
+ )
+ fi
+
+ epytest -m "not network"
+}