summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-25 12:22:47 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-25 12:22:47 -0400
commit0833d64fdf219ef1aa286e57fa076a50cd0a3ea0 (patch)
tree8bc62b08aaa2bfcc61a67ab113267a138fb88574
parentwww-apache/mod_h2: version bump to 0.8.3 (diff)
downloadgentoo-0833d64fdf219ef1aa286e57fa076a50cd0a3ea0.tar.gz
gentoo-0833d64fdf219ef1aa286e57fa076a50cd0a3ea0.tar.bz2
gentoo-0833d64fdf219ef1aa286e57fa076a50cd0a3ea0.zip
net-libs/nghttp2: version bump to 1.2.1 #557282
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.2.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 8c345997583a..0e46d0622aee 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -2,3 +2,4 @@ DIST nghttp2-0.7.15.tar.gz 1350366 SHA256 d6344bf52ef33de7ea328a93bd307f5f8ee716
DIST nghttp2-1.0.1.tar.gz 1350918 SHA256 0f9eec47eeeed98929fbae3609d708cf9422b0213edd8daaa792db9e31463d89 SHA512 365b52864d8cc0cc0d1cb4a08f6926abd2886b7c5a225414db7a3dc0e8bdfe7afecea89e09a93b6a7034d4fc75a263b82ee0e35684900e71e21110683e1084bf WHIRLPOOL 37279a2612add1c9b88a74c0dd6d60b0ffcf9fc940b8559c8d0748f4f0cf6fa452b1135041c593bac0fc0cc3c3857d2cc40138857c59a55670df25dc66cd7a71
DIST nghttp2-1.0.2.tar.gz 1355779 SHA256 6746fa7e282cfe631ad4b69f824bf14951b80e9cb952e825c76eefeb6a3806cd SHA512 6dbd4595dd53cf0a2d429ac5ea16d2f29706a240810c1e9a9d76465b44c6410d8f96b262d640f13331f1b5f0ebdd804a9e9f1ef5ca09f2fb898da2d56902cd64 WHIRLPOOL f0e34ecf30d8ebe3f6325eac7396fbe8fe3df77bbc58796e25fcef7c9e06f0566161c919188b562ba04c5ab84a82150307b70a2890597cc8e32b7bc1437696aa
DIST nghttp2-1.0.5.tar.gz 1356748 SHA256 64e066816606178188bfaf0aa7298e1f44cef943dd9ae936497dab38b3b2569e SHA512 f8b7a79e6174ff501d93333b25954822098d936720a8f4de8a15c83f16c009006aefd05e24977c219661fd63b9fead70eaf5703211bfd9e2bba6a61facbba9c4 WHIRLPOOL 608b1a4494e2aff0c941545c1f49c3c585846d27f5e509ff16c9217309689c47fd7f8fc398b23c83d8aa0ba3f9c2c52af039cd875e47f38630acc50e7c17f717
+DIST nghttp2-1.2.1.tar.gz 1399177 SHA256 133451219eacbdd7e37438dd63296e037621a3323d5c8446c35f0c89ab665c7e SHA512 3d7621243f037f4ec6143dcc3f0ad3489faf3a94ce409909eea47dbb59f2a1d80eaf295c59f7fccc2501f26d706c2355c4c26d8c9649c1479dbc4feac2846800 WHIRLPOOL 9a83045f5f619700db7715f048e0e0958552abfc2248f398880b85d278c12b5789810596a724823d903993f39025f49f7e68ce386220ed6fbfa35bd914a549a5
diff --git a/net-libs/nghttp2/nghttp2-1.2.1.ebuild b/net-libs/nghttp2/nghttp2-1.2.1.ebuild
new file mode 100644
index 000000000000..3a8f8503cdd2
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.2.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI="5"
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc )
+ utils? (
+ >=dev-libs/libev-4.15
+ >=dev-libs/openssl-1.0.2
+ >=sys-libs/zlib-1.2.3
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -name '*.la' -delete
+}