summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-28 19:49:45 -0500
committerSam James <sam@gentoo.org>2024-02-29 00:51:16 +0000
commit086be3cc228e76caa2cba5470b63347e1b953f85 (patch)
tree141e62c1be51bf9d5063250b14ba68e3fdb7cc91
parentmedia-sound/ardour: mark as LTO-unsafe (diff)
downloadgentoo-086be3cc.tar.gz
gentoo-086be3cc.tar.bz2
gentoo-086be3cc.zip
www-client/elinks: sync live
Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--www-client/elinks/elinks-9999.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index 06f1d265ceb6..dc3d36d2c731 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
LUA_COMPAT=( lua5-{1,2,3,4} luajit )
-inherit meson lua-single python-any-r1
+inherit flag-o-matic meson lua-single python-any-r1
DESCRIPTION="Advanced and well-established text-mode web browser"
HOMEPAGE="http://elinks.or.cz/"
@@ -75,6 +75,13 @@ pkg_setup() {
}
src_configure() {
+ # This file is severely broken w.r.t. strict-aliasing and upstream acknowledges it:
+ # https://github.com/rkd77/elinks/blob/d05ce90b35d82109aab320b490e3ca54aa6df057/src/util/lists.h#L14
+ # https://github.com/rkd77/elinks/blob/d05ce90b35d82109aab320b490e3ca54aa6df057/src/meson.build#L44
+ #
+ # Although they force fno-strict-aliasing, we should also not trust the LTO either.
+ filter-lto
+
local emesonargs=(
-Ddocdir="${EPREFIX}"/usr/share/doc/${PF}
-Dhtmldoc=false