summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-02-06 15:35:42 -0500
committerCraig Andrews <candrews@gentoo.org>2024-02-06 15:38:10 -0500
commit088dac7b26f0e8de29c477c6c2c9c1ab5bed8941 (patch)
treee3d1f210ce67d2d95e9cfe1ce851fa1c6a146762
parentdev-libs/libfmt: add CPE tag (diff)
downloadgentoo-088dac7b26f0e8de29c477c6c2c9c1ab5bed8941.tar.gz
gentoo-088dac7b26f0e8de29c477c6c2c9c1ab5bed8941.tar.bz2
gentoo-088dac7b26f0e8de29c477c6c2c9c1ab5bed8941.zip
dev-libs/libfmt: Add lfs flags
Closes: https://github.com/gentoo/gentoo/pull/35205 Signed-off-by: Abhishek Pandit-Subedi <abhishekpandit@chromium.org> Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--dev-libs/libfmt/libfmt-10.2.1-r1.ebuild33
-rw-r--r--dev-libs/libfmt/libfmt-9999.ebuild5
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-libs/libfmt/libfmt-10.2.1-r1.ebuild b/dev-libs/libfmt/libfmt-10.2.1-r1.ebuild
new file mode 100644
index 000000000000..2dbd37cc402c
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-10.2.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ append-lfs-flags
+ local mycmakeargs=(
+ -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
+ -DFMT_LIB_DIR="$(get_libdir)"
+ -DFMT_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/dev-libs/libfmt/libfmt-9999.ebuild b/dev-libs/libfmt/libfmt-9999.ebuild
index 90083087d20e..2dbd37cc402c 100644
--- a/dev-libs/libfmt/libfmt-9999.ebuild
+++ b/dev-libs/libfmt/libfmt-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Small, safe and fast formatting library"
HOMEPAGE="https://github.com/fmtlib/fmt"
@@ -23,6 +23,7 @@ IUSE="test"
RESTRICT="!test? ( test )"
src_configure() {
+ append-lfs-flags
local mycmakeargs=(
-DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
-DFMT_LIB_DIR="$(get_libdir)"