summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-02-10 00:23:46 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-02-10 00:26:33 +0100
commit089730b7066b40b00a303973b4987467552a4610 (patch)
tree006324c735d5ac4ea9888a393786807ff5c247e4
parentdev-python/arsenic: new package, add 21.8 (diff)
downloadgentoo-089730b7.tar.gz
gentoo-089730b7.tar.bz2
gentoo-089730b7.zip
net-analyzer/wapiti: fix install and dependencies
This drops x86 as keyword is missing from some dependencies 3.11 is dropped from python supported version (missing in dep) Closes: https://bugs.gentoo.org/892884 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--net-analyzer/wapiti/files/wapiti-3.1.6-setup_scripts.patch14
-rw-r--r--net-analyzer/wapiti/wapiti-3.1.6.ebuild31
2 files changed, 37 insertions, 8 deletions
diff --git a/net-analyzer/wapiti/files/wapiti-3.1.6-setup_scripts.patch b/net-analyzer/wapiti/files/wapiti-3.1.6-setup_scripts.patch
new file mode 100644
index 000000000000..8df972aeb1bc
--- /dev/null
+++ b/net-analyzer/wapiti/files/wapiti-3.1.6-setup_scripts.patch
@@ -0,0 +1,14 @@
+diff -Naur wapiti3-3.1.6.orig/setup.py wapiti3-3.1.6/setup.py
+--- wapiti3-3.1.6.orig/setup.py 2023-01-31 22:19:30.000000000 +0100
++++ wapiti3-3.1.6/setup.py 2023-02-09 21:56:43.644507169 +0100
+@@ -81,10 +81,6 @@
+ packages=find_packages(exclude=["tests", "tests.*"]),
+ data_files=doc_and_conf_files,
+ include_package_data=True,
+- scripts=[
+- "bin/wapiti",
+- "bin/wapiti-getcookie"
+- ],
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Environment :: Console",
diff --git a/net-analyzer/wapiti/wapiti-3.1.6.ebuild b/net-analyzer/wapiti/wapiti-3.1.6.ebuild
index 3ab9a88d574c..6cb05031672e 100644
--- a/net-analyzer/wapiti/wapiti-3.1.6.ebuild
+++ b/net-analyzer/wapiti/wapiti-3.1.6.ebuild
@@ -4,7 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+# No 3.11 in loguru
+PYTHON_COMPAT=( python3_{9..10} )
PYTHON_REQ_USE='xml(+)'
inherit distutils-r1
@@ -16,22 +17,34 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64"
# Requires httpx-ntlm (to package)
#IUSE="ntlm"
IUSE="test"
# httpx requires brotli and socks, so depending on
# dev-python/socksio and dev-python/brotlicffi
-RDEPEND="dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/aiocache-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-3.8.1[${PYTHON_USEDEP}]
+ >=dev-python/aiosqlite-0.17.0[${PYTHON_USEDEP}]
+ >=dev-python/arsenic-21.8[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.10.0[${PYTHON_USEDEP}]
dev-python/brotlicffi[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/browser-cookie3-0.16.2[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.14[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23.3[${PYTHON_USEDEP}]
+ >=dev-python/loguru-0.5.3[${PYTHON_USEDEP}]
+ >=dev-python/mako-1.1.4[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.4.8[${PYTHON_USEDEP}]
>=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
dev-python/socksio[${PYTHON_USEDEP}]
- dev-python/tld[${PYTHON_USEDEP}]
- dev-python/yaswfp[${PYTHON_USEDEP}]"
+ >=dev-python/sqlalchemy-1.4.26[${PYTHON_USEDEP}]
+ >=dev-python/tld-0.12.5[${PYTHON_USEDEP}]
+ >=dev-python/yaswfp-0.9.3[${PYTHON_USEDEP}]
+ >=net-proxy/mitmproxy-9.0.0[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
# Tests also require unpackaged respx
@@ -43,6 +56,8 @@ BDEPEND+=" test? (
# Many tests require execution of local test php server
RESTRICT="test"
+PATCHES=( "${FILESDIR}"/${PN}-3.1.6-setup_scripts.patch )
+
S=${WORKDIR}/${MY_P}
python_prepare_all() {