summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-08 06:00:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-08 06:06:09 +0100
commit08a061cd9b8c1dc67e55b21156900988fdb3a38b (patch)
tree347930d9572f405271c52b8f47b56ea6088cfcfc
parentdev-python/django: Remove old (diff)
downloadgentoo-08a061cd9b8c1dc67e55b21156900988fdb3a38b.tar.gz
gentoo-08a061cd9b8c1dc67e55b21156900988fdb3a38b.tar.bz2
gentoo-08a061cd9b8c1dc67e55b21156900988fdb3a38b.zip
dev-python/tempest: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tempest/Manifest1
-rw-r--r--dev-python/tempest/tempest-32.0.0.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index d4ff9bc79543..0f72648107ee 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,2 +1 @@
-DIST tempest-32.0.0.tar.gz 1121245 BLAKE2B 00cd2bf7f0869f9040134076e93ebb9d7aa56504788484ed0597d024afb74726df64aa2899dc021ba977cc01814e5e2213b46428d969a73d561e0056b5777d84 SHA512 8770a7067439977720916a8221554836c29afcb18f29716dc513c2eb9f5e09d9b7e123bf98dcb70dafb889594c431efb0367187622e5f0561b24e296a3613734
DIST tempest-33.0.0.tar.gz 1126464 BLAKE2B 14bce9e0baf1878fc30cc5026c7849cda5abc0291706c7cd051827ffb1e15670e653a20ba6c0c898e86a7e1bee498d14139f82887606f5587b7775d18f96595f SHA512 1a34bc81a18121e3be05ab1a2b637aa8bfc41a0a8e11824294c78468762fb5f303ebf9607f5e72aed1cc5b130b26e22bf72c0574472a0de4eca083e899ff6eb0
diff --git a/dev-python/tempest/tempest-32.0.0.ebuild b/dev-python/tempest/tempest-32.0.0.ebuild
deleted file mode 100644
index 003830d1993e..000000000000
--- a/dev-python/tempest/tempest-32.0.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="OpenStack Integration Testing"
-HOMEPAGE="
- https://pypi.org/project/tempest/
- https://docs.openstack.org/tempest/latest/
- https://launchpad.net/tempest/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-RDEPEND="
- >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
- >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
- >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- dev-python/stestr[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # Small subset of tests, which fail as result of not using specific
- # testing environment. Others expect to run suite using stestr.
- rm -r tempest/tests/lib/services/volume/v3/ || die
- rm tempest/tests/test_list_tests.py || die
- rm tempest/tests/lib/cmd/test_check_uuid.py || die
-
- # remove dep on hacking
- rm tempest/tests/test_hacking.py || die
-
- distutils-r1_src_prepare
-}
-
-python_compile() {
- distutils-r1_python_compile
- mv "${BUILD_DIR}"/install/{usr/,}etc || die
-}
-
-python_test() {
- local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1 OS_TEST_TIMEOUT=320
- eunittest -b -s tempest/tests -t .
-}