summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-16 23:38:24 +0000
committerSam James <sam@gentoo.org>2023-03-16 23:50:30 +0000
commit08c4d780246bf814a29b179c25f03bc2f64c04d2 (patch)
treebf5461a7d6b38ffc174cfdca8425cec0908923f0
parentsys-libs/minizip-ng: add 3.0.9 (diff)
downloadgentoo-08c4d780246bf814a29b179c25f03bc2f64c04d2.tar.gz
gentoo-08c4d780246bf814a29b179c25f03bc2f64c04d2.tar.bz2
gentoo-08c4d780246bf814a29b179c25f03bc2f64c04d2.zip
sys-libs/minizip-ng: drop 3.0.7
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/minizip-ng/Manifest1
-rw-r--r--sys-libs/minizip-ng/minizip-ng-3.0.7.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/sys-libs/minizip-ng/Manifest b/sys-libs/minizip-ng/Manifest
index beeafcaea8bb..46d51ee763c0 100644
--- a/sys-libs/minizip-ng/Manifest
+++ b/sys-libs/minizip-ng/Manifest
@@ -1,3 +1,2 @@
-DIST minizip-ng-3.0.7.tar.gz 643065 BLAKE2B e7026a5cc54fac6eba6fd1e79f8d53474966999aec1c24c70ff2207b93314f1e1cf5360841570ace66a30d6178f0057428757c7ba9b2d4bb14feb397142dedcb SHA512 01805ec955514efca32f4beb0e1241e94591d7d1d6119036c55d898a595de038bb18b8a2ffe5dab13101a890d14485aaefdf81680a7c60aa4ab3fd9de63ee991
DIST minizip-ng-3.0.8.tar.gz 643788 BLAKE2B aa937fe8d0e776c8a00754c7a5eae7769b096d044a1b65b124adc0531b757579d8e0e0f5a4784669d9d94a7ea512625160b8b02f908a29e027f31911adf0f524 SHA512 f9742c5fc54ac08d78d7e942e90a7e7f1bc40a2812e7555570bd152ed441dbc5a004b79d2edf32d3fbda64db493cd1a0512d16deb84c0791d3fc86718e9ad0b1
DIST minizip-ng-3.0.9.tar.gz 646390 BLAKE2B ba823e371dd65788404c8628d1e3de74d28bb86a378eb19b2f9636d96b402e43831238a5296d22febe46c58f2e340d8439ad4117db513b949c9cd99a32fa5df6 SHA512 a52c43d0e208eb6acf56f80804fe99c265baec2a60f6cd80fc9ba160ca3c076e6c118be9108db84728310b14640cab0e0d301d4c763713c90bd344990a43f5fd
diff --git a/sys-libs/minizip-ng/minizip-ng-3.0.7.ebuild b/sys-libs/minizip-ng/minizip-ng-3.0.7.ebuild
deleted file mode 100644
index 12ebd223606a..000000000000
--- a/sys-libs/minizip-ng/minizip-ng-3.0.7.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Worth keeping an eye on 'develop' branch upstream for possible backports,
-# as they copied this practice from sys-libs/zlib upstream.
-
-inherit cmake
-
-DESCRIPTION="Fork of the popular zip manipulation library found in the zlib distribution"
-HOMEPAGE="https://github.com/zlib-ng/minizip-ng"
-SRC_URI="https://github.com/zlib-ng/minizip-ng/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="compat openssl test zstd"
-RESTRICT="!test? ( test )"
-
-# Automagically prefers sys-libs/zlib-ng if installed, so let's
-# just depend on it as presumably it's better tested anyway.
-RDEPEND="
- app-arch/bzip2
- app-arch/xz-utils
- sys-libs/zlib-ng
- virtual/libiconv
- compat? ( !sys-libs/zlib[minizip] )
- openssl? ( dev-libs/openssl:= )
- zstd? ( app-arch/zstd:= )
-"
-DEPEND="
- ${RDEPEND}
- test? ( dev-cpp/gtest )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.0.7-system-gtest.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DMZ_COMPAT=$(usex compat)
-
- -DMZ_BUILD_TESTS=$(usex test)
- -DMZ_BUILD_UNIT_TESTS=$(usex test)
-
- -DMZ_FETCH_LIBS=OFF
- -DMZ_FORCE_FETCH_LIBS=OFF
-
- # Compression library options
- -DMZ_ZLIB=ON
- -DMZ_BZIP2=ON
- -DMZ_LZMA=ON
- -DMZ_ZSTD=$(usex zstd)
- -DMZ_LIBCOMP=OFF
-
- # Encryption support options
- -DMZ_PKCRYPT=ON
- -DMZ_WZAES=ON
- -DMZ_OPENSSL=$(usex openssl)
- # TODO: Re-enable, ideally unconditionally, for arc4random
- # Revisit when https://github.com/zlib-ng/minizip-ng/pull/648 fixed
- -DMZ_LIBBSD=ON
- -DMZ_SIGNING=ON
-
- # Character conversion options
- -DMZ_ICONV=ON
- )
-
- cmake_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # TODO: investigate
- -E "(raw-unzip-pkcrypt|raw-append-unzip-pkcrypt|raw-erase-unzip-pkcrypt|deflate-unzip-pkcrypt|deflate-append-unzip-pkcrypt|deflate-erase-unzip-pkcrypt|bzip2-unzip-pkcrypt|bzip2-append-unzip-pkcrypt|bzip2-erase-unzip-pkcrypt|lzma-unzip-pkcrypt|lzma-append-unzip-pkcrypt|lzma-erase-unzip-pkcrypt|xz-unzip-pkcrypt|xz-append-unzip-pkcrypt|xz-erase-unzip-pkcrypt|zstd-unzip-pkcrypt|zstd-append-unzip-pkcrypt|zstd-erase-unzip-pkcrypt)"
- )
-
- # TODO: A bunch of tests end up looping and writing over each other's files
- # It gets better with a patch applied (see https://github.com/zlib-ng/minizip-ng/issues/623#issuecomment-1264518994)
- # but still hangs.
- cmake_src_test -j1
-}
-
-src_install() {
- cmake_src_install
-
- if use compat ; then
- ewarn "minizip-ng is experimental and replacing the system zlib[minizip] is dangerous"
- ewarn "Please be careful!"
- fi
-}