summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-10-25 21:20:53 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-10-25 21:20:53 +0100
commit08c8a438bc81f427b3a10ed48f46496ccb93874e (patch)
tree6de76caf93872efbb793edca1e73d597c7eedf00
parentdev-ml/ocamlweb: x86 stable (bug #750284) (diff)
downloadgentoo-08c8a438.tar.gz
gentoo-08c8a438.tar.bz2
gentoo-08c8a438.zip
dev-python/zipp: bump to 3.4.0
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.4.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index fa7faf862b60..6ccc6ae80efd 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,3 +1,4 @@
DIST zipp-3.1.0.tar.gz 14808 BLAKE2B fb5524c2619e51c5f8c1b85fa819d1001e6296df6c9d5320c6ab3ec88fa5c932c139161e621d51b2827ef40402bb2492b8b08e470b7333e847495ec690024879 SHA512 bb8dea71eccc4f3b18fc816dae700582c3feb72f346e115bb2d1adc336f121304a285e4d5dad48d15b386b9e137c6e1d1793ef50d22b6bd697812a661817684e
DIST zipp-3.3.1.tar.gz 17336 BLAKE2B a71e4a059f5c1f3d7a91032f48686aeda64b5bdd83da45fadc24d6662d03944e3ac9484a1a1ec345baf9ebc4f64b73bf4d880fcdda46e23a17291b6e06a7a72e SHA512 0504e42b09148e5db45d8368e5a9d7b857474d81d18561342cac3306e26944df291c2961114b568940ef003387461ac55b673ae21b2f5e5820194119173fd732
DIST zipp-3.3.2.tar.gz 15570 BLAKE2B a508d22c1e938ab865e3c6495120a01f79416ac3fa31565eaa4b066b049797ee16e0850e53e0d440e135bf7605b5396cc0fc8798272b59b692d2c004682d8395 SHA512 ecd90625a92167c7751bbe077b63577f236b05a9946b7f4a0629488856e8b275e3c03e5daefc8b89140f43617c0f4440e2baa6d1ff982e3babe3954daadee75a
+DIST zipp-3.4.0.tar.gz 15638 BLAKE2B c06f68b9a23e6ba560cf7b703150e4b14d8bbeb5c8712c54257f587de9a44eb853804495eaecff2ad17261304da9b9433951cbb9b17e3f35446406e4e4fe517d SHA512 c791e72f05a92110037cbee7153103e47ec536994d9e86cdecb34c602839c0bf5e6e4ab4ce56d6a44c7eb4f7a555ba531df8c986e302654c624f59e2217bf10f
diff --git a/dev-python/zipp/zipp-3.4.0.ebuild b/dev-python/zipp/zipp-3.4.0.ebuild
new file mode 100644
index 000000000000..46fb971a3bc6
--- /dev/null
+++ b/dev-python/zipp/zipp-3.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
+ test? ( dev-python/jaraco-itertools[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Skip a potentially flaky performance test
+ sed -i -e '/^import func_timeout\|^ *@func_timeout\.func_set_timeout/d' \
+ -e 's/test_implied_dirs_performance/_&/' test_zipp.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Ignoring zipp.py from ${S} avoids ImportPathMismatchError with Python < 3.8
+ # by ensuring only zipp from ${BUILD_DIR} is loaded
+ pytest --ignore zipp.py -vv || die "Tests fail with ${EPYTHON}"
+}