summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-10-29 12:44:31 +0200
committerJohannes Huber <johu@gentoo.org>2016-10-29 12:46:52 +0200
commit08cb681f8c0844f7fc7fffdac14a5345302da0ea (patch)
tree976b70ab10b23698b471bcf9c4a365d7f21a4eac
parentapp-emulation/dosemu: drop old (diff)
downloadgentoo-08cb681f.tar.gz
gentoo-08cb681f.tar.bz2
gentoo-08cb681f.zip
media-sound/tomahawk: Version bump 0.9.0 pre snapshot
Last release is ancient, segfaults with Qt5 (bug #591344) and fails to build with latest quazip (bug #598262). Gentoo-bug: 591344 Gentoo-bug: 598262 Package-Manager: portage-2.3.2
-rw-r--r--media-sound/tomahawk/Manifest1
-rw-r--r--media-sound/tomahawk/tomahawk-0.9.0_pre20161029.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/media-sound/tomahawk/Manifest b/media-sound/tomahawk/Manifest
index 3187743feb8d..e64b76de4ffa 100644
--- a/media-sound/tomahawk/Manifest
+++ b/media-sound/tomahawk/Manifest
@@ -1 +1,2 @@
DIST tomahawk-0.8.4.tar.bz2 8611412 SHA256 0fb04bc6b7009e17186b3d384057939727c6f289d22f7f9a5ed2c9c9cd800449 SHA512 5b312f593eac39d06de05e24d4ce429122d0777a9d52d6db8c65309ac283d7ae560c2fc189b186f0f8b1a7bbe1135ed0d59e1d850de6a93655e53efe4f5317c7 WHIRLPOOL 3577f47f13b191f0bea42d7c30c00ad8e6346afc7527eb5f5ecb81185183a8e99dcc0559414afbba485db5d80d2e5f9830fe341d4563d3d7427a98f54382e013
+DIST tomahawk-0.9.0_pre20161029.tar.xz 7945264 SHA256 de4005fd68dfb11380419829e009f19b901c4b14ccec6dd63400b21612886271 SHA512 fcfe810f167de936ed5457b3f30d7e17ef5708389800c6be85a1f867fc75a6973fcc04181719910c127dcc226619bd7ea31e0273b981f84c8122a2e1709fbcf9 WHIRLPOOL b914df1f2a26cc18af021ef6fce5511b2a103d7243340bcaec3d0c98fa90fc2fcda32cabc8022c2106d9bd9dffa777765e17433dc268f2c317537716c31928f6
diff --git a/media-sound/tomahawk/tomahawk-0.9.0_pre20161029.ebuild b/media-sound/tomahawk/tomahawk-0.9.0_pre20161029.ebuild
new file mode 100644
index 000000000000..43d4b289ad2c
--- /dev/null
+++ b/media-sound/tomahawk/tomahawk-0.9.0_pre20161029.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ # SRC_URI="http://download.tomahawk-player.org/${P}.tar.bz2"
+ SRC_URI="http://dev.gentoo.org/~johu/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+else
+ EGIT_REPO_URI="git://github.com/tomahawk-player/${PN}.git"
+fi
+
+DESCRIPTION="Multi-source social music player"
+HOMEPAGE="http://tomahawk-player.org/"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+IUSE="+hatchet telepathy xmpp"
+
+CDEPEND="
+ $(add_frameworks_dep attica)
+ $(add_qt_dep designer)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ $(add_qt_dep qtxml)
+ app-crypt/qca:2[qt5]
+ dev-cpp/lucene++
+ dev-cpp/sparsehash
+ dev-libs/boost:=
+ dev-libs/qtkeychain:=[qt5]
+ >=dev-libs/quazip-0.7.2[qt5]
+ >=media-libs/libechonest-2.3.1:=[qt5]
+ media-libs/liblastfm[qt5]
+ >=media-libs/taglib-1.8.0
+ media-video/vlc:=[flac,dvbpsi,ffmpeg,mp3]
+ >=net-libs/gnutls-3.2:=
+ x11-libs/libX11
+ hatchet? ( dev-cpp/websocketpp )
+ telepathy? ( net-libs/telepathy-qt[qt5] )
+ xmpp? ( net-libs/jreen[qt5] )
+"
+DEPEND="${CDEPEND}
+ $(add_qt_dep linguist-tools)
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${CDEPEND}
+ app-crypt/qca:2[ssl]
+"
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+PATCHES=( "${FILESDIR}/${PN}-liblastfm-cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_CRASHREPORTER=OFF
+ -DBUILD_TESTS=OFF
+ -DBUILD_TOOLS=OFF
+ -DBUILD_WITH_QT4=OFF
+ -DWITH_KDE4=OFF
+ -DBUILD_HATCHET=$(usex hatchet)
+ -DWITH_TelepathyQt=$(usex telepathy)
+ -DWITH_Jreen=$(usex xmpp)
+ )
+
+ if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ mycmakeargs+=( -DBUILD_RELEASE=ON )
+ fi
+
+ kde5_src_configure
+}