summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-11-25 08:07:41 +1000
committerSam James <sam@gentoo.org>2023-11-25 03:59:23 +0000
commit08d5bd818814b1831e6ebec5ee81c0853d2f0f72 (patch)
tree739b8d989ade4c454c0738834ee6246d58bf37e7
parentapp-arch/createrepo_c: add 1.0.2 (diff)
downloadgentoo-08d5bd818814b1831e6ebec5ee81c0853d2f0f72.tar.gz
gentoo-08d5bd818814b1831e6ebec5ee81c0853d2f0f72.tar.bz2
gentoo-08d5bd818814b1831e6ebec5ee81c0853d2f0f72.zip
app-arch/createrepo_c: drop 0.21.1, 1.0.0
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Closes: https://github.com/gentoo/gentoo/pull/33971 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-arch/createrepo_c/Manifest2
-rw-r--r--app-arch/createrepo_c/createrepo_c-0.21.1.ebuild65
-rw-r--r--app-arch/createrepo_c/createrepo_c-1.0.0.ebuild67
3 files changed, 0 insertions, 134 deletions
diff --git a/app-arch/createrepo_c/Manifest b/app-arch/createrepo_c/Manifest
index 732f4796a9f1..b36b5eb001a5 100644
--- a/app-arch/createrepo_c/Manifest
+++ b/app-arch/createrepo_c/Manifest
@@ -1,3 +1 @@
-DIST createrepo_c-0.21.1.tar.gz 626012 BLAKE2B 87e7fff68bb06c9552ea80eada625e58130d171db48b0a1aa4965150b136e62c656e368e1bc7cc057e5fad105fff620bb37e171e367eb688725d2089e4181db4 SHA512 453b857ecde5aa63f57e4a783855e4f4c32a041b68c0bfbb5d5b06bc0010d6cd043ba374cb880cce1d0de160a37df2df2688e9886bf9c8d92c09fe530aa36dfe
-DIST createrepo_c-1.0.0.tar.gz 628628 BLAKE2B fed99e3eb7e2bb6dc9a045abb0c35c00bf4a733a1a70780109cda00b0db0bcf2ab96b466fcd4ce5b063642e900a6fb3d853870ea3af28da6c2b3af3655a49b2e SHA512 b412dd56c4e0b69467708a3646bf276b9c3a970b2f89f269b5c65a4efb961ed42769b9fca9d333588d2726e85fc80050a83a2e5b83e296f7e8b028ddd2bf9cf9
DIST createrepo_c-1.0.2.tar.gz 629680 BLAKE2B 441b4bb6973c67325403a0ab3a34cf475daddd41c7823a6634c576f6ab5ff0b9354d8941bbd67223b9fbd0c60a0cb81130b125d66d7eb7850abc818eeeffd437 SHA512 b4ceba2f0b558843bdc04be30a10ffb785eea0beb6e1f1efe7373b2a47c8aba554f1a881194c02d1b3980332912d92aa84fdda079324b60c2d57c55e43fa9eb6
diff --git a/app-arch/createrepo_c/createrepo_c-0.21.1.ebuild b/app-arch/createrepo_c/createrepo_c-0.21.1.ebuild
deleted file mode 100644
index 7433f2a6011f..000000000000
--- a/app-arch/createrepo_c/createrepo_c-0.21.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="C implementation of createrepo"
-HOMEPAGE="https://github.com/rpm-software-management/createrepo_c"
-if [[ ${PV} = 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/rpm-software-management/createrepo_c.git"
-else
- SRC_URI="https://github.com/rpm-software-management/createrepo_c/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="legacy test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- app-arch/bzip2:=
- app-arch/drpm
- app-arch/rpm
- app-arch/xz-utils
- app-arch/zchunk
- dev-db/sqlite:3
- dev-libs/glib:2
- dev-libs/libxml2
- dev-libs/openssl:=
- net-misc/curl
- sys-apps/file
- sys-libs/libmodulemd
- sys-libs/zlib:=
-"
-
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_DRPM=ON
- # As best I can tell, this enables distribution as a wheel. No need for this on gentoo!
- -DENABLE_PYTHON=OFF
- # Upstream enables some 'Legacy' stuff by default, let's put that behind a USE flag
- -DENABLE_LEGACY_WEAKDEPS=$(usex legacy ON OFF)
- -DWITH_LEGACY_HASHES=$(usex legacy ON OFF)
- -DWITH_LIBMODULEMD=ON
- -DWITH_ZCHUNK=ON
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- # Tests have a magic target!
- use test && cmake_src_compile tests
-}
-
-src_test() {
- "${S}"_build/tests/run_tests.sh || die "Failed to run C library tests"
-}
diff --git a/app-arch/createrepo_c/createrepo_c-1.0.0.ebuild b/app-arch/createrepo_c/createrepo_c-1.0.0.ebuild
deleted file mode 100644
index a9a502907e62..000000000000
--- a/app-arch/createrepo_c/createrepo_c-1.0.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="C implementation of createrepo"
-HOMEPAGE="https://github.com/rpm-software-management/createrepo_c"
-if [[ ${PV} = 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/rpm-software-management/createrepo_c.git"
-else
- SRC_URI="https://github.com/rpm-software-management/createrepo_c/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="legacy test zstd"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- app-arch/bzip2:=
- app-arch/drpm
- app-arch/rpm
- app-arch/xz-utils
- app-arch/zchunk
- dev-db/sqlite:3
- dev-libs/glib:2
- dev-libs/libxml2
- dev-libs/openssl:=
- net-misc/curl
- sys-apps/file
- sys-libs/libmodulemd
- sys-libs/zlib:=
- zstd? ( app-arch/zstd:= )
-"
-
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_DRPM=ON
- # As best I can tell, this enables distribution as a wheel. No need for this on gentoo!
- -DENABLE_PYTHON=OFF
- # Upstream enables some 'Legacy' stuff by default, let's put that behind a USE flag
- -DENABLE_LEGACY_WEAKDEPS=$(usex legacy ON OFF)
- -DWITH_LEGACY_HASHES=$(usex legacy ON OFF)
- -DWITH_LIBMODULEMD=ON
- -DWITH_ZCHUNK=ON
- -DWITH_ZSTD=$(usex zstd)
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- # Tests have a magic target!
- use test && cmake_src_compile tests
-}
-
-src_test() {
- "${S}"_build/tests/run_tests.sh || die "Failed to run C library tests"
-}