summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-01-03 17:30:28 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-27 14:59:51 +0100
commit08ebd03accb74263e11362dbdbc58f064809f6a5 (patch)
tree28f83b558bd96a26c8dfa388f89765ca00160ce0
parentapp-benchmarks/sysbench: bump to 1.0.12 (diff)
downloadgentoo-08ebd03a.tar.gz
gentoo-08ebd03a.tar.bz2
gentoo-08ebd03a.zip
app-admin/filebeat: version bump to 6.1.1
Closes: https://github.com/gentoo/gentoo/pull/6601 Package-Manager: Portage-2.3.18, Repoman-2.3.6
-rw-r--r--app-admin/filebeat/Manifest1
-rw-r--r--app-admin/filebeat/filebeat-6.1.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/filebeat/Manifest b/app-admin/filebeat/Manifest
index 5b8e8df7f866..aca912b54382 100644
--- a/app-admin/filebeat/Manifest
+++ b/app-admin/filebeat/Manifest
@@ -1,3 +1,4 @@
DIST filebeat-5.5.2.tar.gz 18075191 BLAKE2B 9786cb8f3db003c86e4bc6d56fcac660b615e7e6ad82d0912f70c545f2af3caab605be739481355466438a1769c20b28db576d208af6b0af9620ce6408068215 SHA512 ad92b41a9ceaad6c6e6fc80d0adccd7fe03a7056d121484bcf35c6a46b2061a5ef6d32121dd12d59b51e7678769da5c405b1d549fa130631ae3f1989b78fba48
DIST filebeat-5.6.5.tar.gz 18145468 BLAKE2B 57f3320012d8c17b7b961dd6d843e982e3cc5fe0f39658ca5ccc2fb9056c8dd4527306b7cfe483d3fa39bef5892dd22c4f07f24aad1e804bd76cdda94b56a3e8 SHA512 f1c8ffa2521e0e15a14850199c3da83d8f8489d5f97364b205ee8120b56e2ae47055c78ed6a5ef2d0296f449339efa05f2d7bce7282b1e7f2e044d7ed3244d4c
DIST filebeat-6.0.1.tar.gz 15150919 BLAKE2B 40149de3257d78a737d71f59f8be91a3bd60185f716ecc89dbe373283ab6481afe709ff573efb8b1079f2c571c6de036bd705dd082c3cba1eda44d282409247c SHA512 baf21acf38409b398f261509d25d2b009342fdde1fcd824c99d16cc279355ae5eb029699a5a7e3b6e58abdbed4ef5fda1b4058ed94b807fd5964ad24828585e2
+DIST filebeat-6.1.1.tar.gz 17061456 BLAKE2B 5a5d23618f8140f3815c499305d99ae3dc4c4caa49535043040387922f924ee49a9494b5139f34a70d74173d97332b92909fc74e2f91a2fc0f288ef5d1493ade SHA512 54e85cfce58ba724f6b2892f115ac9ef5b1bb89ce8dc6f2a977e50ccfc07cf95fc578e46e0cadd96acd90c59f4b01446851b93c519afa094ff6dcdb7e716219a
diff --git a/app-admin/filebeat/filebeat-6.1.1.ebuild b/app-admin/filebeat/filebeat-6.1.1.ebuild
new file mode 100644
index 000000000000..086d5c7ed5cc
--- /dev/null
+++ b/app-admin/filebeat/filebeat-6.1.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.9.2"
+RDEPEND="!app-admin/filebeat-bin"
+
+ELASTIC="${WORKDIR}/src/github.com/elastic"
+BEATS="${ELASTIC}/beats"
+S="${BEATS}"
+
+src_unpack() {
+ mkdir -p "${ELASTIC}" || die
+ unpack ${P}.tar.gz
+ mv beats-${PV} "${BEATS}" || die
+}
+
+src_compile() {
+ cd ${BEATS}/filebeat || die
+ GOPATH="${WORKDIR}" emake
+}
+
+src_install() {
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd.1" ${PN}
+
+ docinto examples
+ dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/$(get_version_component_range 1-2)/upgrading.html"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT%/}/usr/share/doc/${PF}/examples"
+}