summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-16 00:31:08 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-16 02:29:39 -0500
commit08efb38659779f40aa9ec3bc79ce9216dd13a84f (patch)
treeef0764194ee66112e3bb7e1f04f45fbf34af3aac
parentgames-board/scid: EAPI7->8, enable py3.11 (diff)
downloadgentoo-08efb38659779f40aa9ec3bc79ce9216dd13a84f.tar.gz
gentoo-08efb38659779f40aa9ec3bc79ce9216dd13a84f.tar.bz2
gentoo-08efb38659779f40aa9ec3bc79ce9216dd13a84f.zip
games-puzzle/pingus: EAPI7->8, enable py3.11
scons junk seems to work 3.11 still, ebuild could need more attention but given upstream has removed scons it's likely not worth spending time on (then again, it may be a long time before a release still, development seem to have slowed down). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-puzzle/pingus/pingus-0.7.6-r4.ebuild (renamed from games-puzzle/pingus/pingus-0.7.6-r3.ebuild)16
1 files changed, 6 insertions, 10 deletions
diff --git a/games-puzzle/pingus/pingus-0.7.6-r3.ebuild b/games-puzzle/pingus/pingus-0.7.6-r4.ebuild
index 4ab22971d918..3efc2e7eeb36 100644
--- a/games-puzzle/pingus/pingus-0.7.6-r3.ebuild
+++ b/games-puzzle/pingus/pingus-0.7.6-r4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit desktop flag-o-matic python-any-r1 scons-utils toolchain-funcs xdg
DESCRIPTION="Free Lemmings clone"
@@ -16,13 +16,13 @@ KEYWORDS="~amd64 ~x86"
IUSE="opengl music"
RDEPEND="
+ dev-libs/boost:=
+ media-libs/libpng:=
media-libs/libsdl[joystick,opengl?,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer
music? ( media-libs/sdl-mixer[mod] )
- opengl? ( virtual/opengl )
- media-libs/libpng:0=
- dev-libs/boost:=
+ opengl? ( media-libs/libglvnd[X] )
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
@@ -36,12 +36,8 @@ PATCHES=(
"${FILESDIR}"/${P}-python3.patch
)
-src_prepare() {
- xdg_src_prepare
- strip-flags
-}
-
src_compile() {
+ strip-flags
escons \
CXX="$(tc-getCXX)" \
CCFLAGS="${CXXFLAGS}" \