summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-01 16:31:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-01 16:35:08 -0500
commit09129166282ace2cac4fbec822e21479254abc77 (patch)
treef62813436078357e12d04879ac4be4cfd99a4fd0
parentapp-crypt/certbot: switch to eclass for distutils depend (diff)
downloadgentoo-09129166.tar.gz
gentoo-09129166.tar.bz2
gentoo-09129166.zip
app-crypt/certbot-nginx: add DISTUTILS_USE_SETUPTOOLS=rdepend
closes: https://bugs.gentoo.org/745858 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-1.7.0.ebuild5
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-1.8.0.ebuild5
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-9999.ebuild5
3 files changed, 6 insertions, 9 deletions
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.7.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.7.0.ebuild
index 3fd20448a069..51368c8f499e 100644
--- a/app-crypt/certbot-nginx/certbot-nginx-1.7.0.ebuild
+++ b/app-crypt/certbot-nginx/certbot-nginx-1.7.0.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=(python{3_6,3_7,3_8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
@@ -23,11 +24,9 @@ LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
+RDEPEND="
>=app-crypt/acme-1.4.0[${PYTHON_USEDEP}]
>=app-crypt/certbot-1.6.0[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
>=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.8.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.8.0.ebuild
index 1d92bc0c30fa..383e16073c64 100644
--- a/app-crypt/certbot-nginx/certbot-nginx-1.8.0.ebuild
+++ b/app-crypt/certbot-nginx/certbot-nginx-1.8.0.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=(python{3_6,3_7,3_8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
@@ -23,11 +24,9 @@ LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
+RDEPEND="
>=app-crypt/acme-1.4.0[${PYTHON_USEDEP}]
>=app-crypt/certbot-1.6.0[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
>=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
diff --git a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
index 1d92bc0c30fa..383e16073c64 100644
--- a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
+++ b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=(python{3_6,3_7,3_8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
@@ -23,11 +24,9 @@ LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
+RDEPEND="
>=app-crypt/acme-1.4.0[${PYTHON_USEDEP}]
>=app-crypt/certbot-1.6.0[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
>=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"