summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-29 20:58:43 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-29 21:04:10 +0100
commit093b263b263af53d6f426fe979991bbb19edafdc (patch)
treeee856be1f61ad7acd64774f05306153a22fc6cf6
parentsys-libs/llvm-libunwind: Check out cmake/ directory in 14.x (diff)
downloadgentoo-093b263b.tar.gz
gentoo-093b263b.tar.bz2
gentoo-093b263b.zip
sys-libs/llvm-libunwind: Use LIBUNWIND_INSTALL_HEADERS in 14.x
Thanks to Arfrever for the suggestion. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild8
1 files changed, 1 insertions, 7 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild
index 3de0ff0f04be..cd73db419d28 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild
@@ -55,6 +55,7 @@ multilib_src_configure() {
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}
-DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
-DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
+ -DLIBUNWIND_INSTALL_HEADERS=ON
-DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
-DLLVM_INCLUDE_TESTS=$(usex test)
@@ -133,10 +134,3 @@ multilib_src_test() {
local -x LIT_PRESERVES_TMP=1
cmake_build check-unwind
}
-
-multilib_src_install() {
- cmake_src_install
-
- # install headers like sys-libs/libunwind
- doheader "${S}"/include/*.h
-}