summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-05-02 09:48:54 +0200
committerJohannes Huber <johu@gentoo.org>2016-05-02 10:02:08 +0200
commit093beb6a1945520416a5179bd5c77ab554ae09d8 (patch)
treea569634edaa6cabfd26de2598454e971013e485f
parentpackage.mask: Masked imagemagick-7.0.1.0 (broken reverse deps). (diff)
downloadgentoo-093beb6a.tar.gz
gentoo-093beb6a.tar.bz2
gentoo-093beb6a.zip
media-libs/qimageblitz: Set minimum cmake version
Revision bump adds upstream patch which sets minimum cmake version. Gentoo-bug: 581788 Package-Manager: portage-2.2.28
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-0.0.6-cmake.patch12
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-0.0.6-exec-stack.patch9
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-0.0.6-gcc.patch4
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch6
-rw-r--r--media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild40
5 files changed, 66 insertions, 5 deletions
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6-cmake.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6-cmake.patch
new file mode 100644
index 000000000000..adb183de8f75
--- /dev/null
+++ b/media-libs/qimageblitz/files/qimageblitz-0.0.6-cmake.patch
@@ -0,0 +1,12 @@
+Index: CMakeLists.txt
+===================================================================
+--- a/CMakeLists.txt (revision 1209280)
++++ b/CMakeLists.txt (revision 1209281)
+@@ -1,5 +1,7 @@
+ project(blitz)
+
++cmake_minimum_required(VERSION 2.6.4)
++
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules )
+ find_package(Qt4 REQUIRED)
+ # properly set up compile flags (QT_DEBUG/QT_NO_DEBUG, ...)
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6-exec-stack.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6-exec-stack.patch
new file mode 100644
index 000000000000..170bd709aa11
--- /dev/null
+++ b/media-libs/qimageblitz/files/qimageblitz-0.0.6-exec-stack.patch
@@ -0,0 +1,9 @@
+Index: blitz/asm_scale.S
+===================================================================
+--- a/blitz/asm_scale.S (revision 1204247)
++++ b/blitz/asm_scale.S (revision 1204248)
+@@ -1,3 +1,4 @@
++.section .note.GNU-stack,"",%progbits
+
+ #if defined(__EMX__)
+ /* Due to strange behaviour of as.exe we use this macros */
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6-gcc.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6-gcc.patch
index 9b4d8128cb1d..b956d2dfd595 100644
--- a/media-libs/qimageblitz/files/qimageblitz-0.0.6-gcc.patch
+++ b/media-libs/qimageblitz/files/qimageblitz-0.0.6-gcc.patch
@@ -1,5 +1,5 @@
---- blitz/CMakeLists.txt
-+++ blitz/CMakeLists.txt
+--- a/blitz/CMakeLists.txt
++++ b/blitz/CMakeLists.txt
@@ -31,12 +31,8 @@
if(HAVE_MMX)
diff --git a/media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch b/media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch
index 8692c240f7bb..911c56b48ccb 100644
--- a/media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch
+++ b/media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch
@@ -1,6 +1,6 @@
-diff -uar qimageblitz/blitz/asm_scale.S qimageblitz~/blitz/asm_scale.S
---- qimageblitz-orig/blitz/asm_scale.S 2007-10-17 01:17:57.000000000 +0200
-+++ qimageblitz/blitz/asm_scale.S 2007-10-17 01:19:12.000000000 +0200
+diff -Naur qimageblitz/blitz/asm_scale.S qimageblitz~/blitz/asm_scale.S
+--- a/qimageblitz-orig/blitz/asm_scale.S 2007-10-17 01:17:57.000000000 +0200
++++ b/qimageblitz/blitz/asm_scale.S 2007-10-17 01:19:12.000000000 +0200
@@ -814,3 +814,7 @@
SIZE(qimageScale_mmx_AARGBA)
diff --git a/media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild b/media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild
new file mode 100644
index 000000000000..c57aa1c4b62c
--- /dev/null
+++ b/media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Graphical effect and filter library by KDE"
+HOMEPAGE="https://websvn.kde.org/trunk/kdesupport/qimageblitz/"
+SRC_URI="mirror://kde/stable/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+SLOT="0"
+IUSE="cpu_flags_x86_3dnow altivec debug cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2"
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-exec-stack.patch"
+ "${FILESDIR}/${P}-gcc.patch"
+ "${FILESDIR}/${P}-cmake.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DHAVE_ALTIVEC=$(usex altivec)
+ -DHAVE_3DNOW=$(usex cpu_flags_x86_3dnow)
+ -DHAVE_MMX=$(usex cpu_flags_x86_mmx)
+ -DHAVE_SSE=$(usex cpu_flags_x86_sse)
+ -DHAVE_SSE2=$(usex cpu_flags_x86_sse2)
+ )
+
+ cmake-utils_src_configure
+}