summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-10-31 11:30:30 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-31 11:31:20 -0400
commit09633861186f28e8e2c0dd9b5d3011375c5b4ef6 (patch)
tree4174de1e5c1214c4cb09cddc276bed5215ab20a1
parentapp-misc/mosquitto: Drop old versions (diff)
downloadgentoo-09633861.tar.gz
gentoo-09633861.tar.bz2
gentoo-09633861.zip
dev-util/ccls: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-util/ccls/Manifest1
-rw-r--r--dev-util/ccls/ccls-0.20210330-r1.ebuild51
-rw-r--r--dev-util/ccls/ccls-0.20210330.ebuild46
-rw-r--r--dev-util/ccls/files/ccls-0.20210330-llvm-cmake.patch18
-rw-r--r--dev-util/ccls/files/ccls-0.20210330-llvm14.patch139
5 files changed, 0 insertions, 255 deletions
diff --git a/dev-util/ccls/Manifest b/dev-util/ccls/Manifest
index c8afbf5f5510..ea82616a5736 100644
--- a/dev-util/ccls/Manifest
+++ b/dev-util/ccls/Manifest
@@ -1,2 +1 @@
-DIST ccls-0.20210330.tar.gz 160487 BLAKE2B f87539a5e726a8742552d811d741c379d62c146bed835c7fa8d32ab5eb1f609513f80051faf07bbb8e346f176c02ab3e54b3446d5e28dae744468f2209a9d037 SHA512 dd78c040c2a51d6b47f8dd2d8bdc0661111f26b9233ffeb41216254b1b0ad0f634190784e6b8c2d7b36475c13020356342d83a9f80047d7da75ce21ca8885b16
DIST ccls-0.20220729.tar.gz 160861 BLAKE2B db096f0f1e1d56967086e2711af63f4882e77128236b3d1af3cc107a3b320aa29bcacd4b21769904727261b5608bb2c8409dbb0f3b0d9b0907a94f3bb7c966c8 SHA512 63cb4eace1700118f9c8c4d2f4be40aac948f9c658485c8e3f49dcc863ce7bdd8b6de810b95ec8f46c943b65c8aa5fa643b110a6b981a2e43f57569d897d36c1
diff --git a/dev-util/ccls/ccls-0.20210330-r1.ebuild b/dev-util/ccls/ccls-0.20210330-r1.ebuild
deleted file mode 100644
index f2069853b3f4..000000000000
--- a/dev-util/ccls/ccls-0.20210330-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
-
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
- LLVM_MAX_SLOT=9999
-else
- LLVM_MAX_SLOT=14
-fi
-
-inherit cmake llvm ${GIT_ECLASS}
-
-DESCRIPTION="C/C++/ObjC language server"
-HOMEPAGE="https://github.com/MaskRay/ccls"
-
-if [[ ${PV} == *9999 ]] ; then
- SRC_URI=""
-else
- SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-# We only depend on Clang because of a quirk in how dependencies work
-# See comment in llvm.eclass docs
-DEPEND="
- dev-libs/rapidjson
- <sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):=
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-llvm-cmake.patch
- "${FILESDIR}"/${P}-llvm14.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DCCLS_VERSION=${PV}
- -DUSE_SYSTEM_RAPIDJSON=ON
- -DCLANG_LINK_CLANG_DYLIB=1
- )
- cmake_src_configure
-}
diff --git a/dev-util/ccls/ccls-0.20210330.ebuild b/dev-util/ccls/ccls-0.20210330.ebuild
deleted file mode 100644
index 9b48ac669633..000000000000
--- a/dev-util/ccls/ccls-0.20210330.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
-
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
-fi
-
-inherit cmake ${GIT_ECLASS}
-
-DESCRIPTION="C/C++/ObjC language server"
-HOMEPAGE="https://github.com/MaskRay/ccls"
-
-if [[ ${PV} == *9999 ]] ; then
- SRC_URI=""
-else
- SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-DEPEND="
- dev-libs/rapidjson
- sys-devel/clang:=
- sys-devel/llvm:=
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-llvm-cmake.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DCCLS_VERSION=${PV}
- -DUSE_SYSTEM_RAPIDJSON=ON
- -DCLANG_LINK_CLANG_DYLIB=1
- )
- cmake_src_configure
-}
diff --git a/dev-util/ccls/files/ccls-0.20210330-llvm-cmake.patch b/dev-util/ccls/files/ccls-0.20210330-llvm-cmake.patch
deleted file mode 100644
index 8d8db4483db5..000000000000
--- a/dev-util/ccls/files/ccls-0.20210330-llvm-cmake.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-https://github.com/MaskRay/ccls/commit/dce86b1362acbabb8f997869fdaa27adc67f9a55.patch
-https://bugs.gentoo.org/835916
-
-From: Fangrui Song <i@maskray.me>
-Date: Wed, 15 Dec 2021 10:13:29 -0800
-Subject: [PATCH] cmake: Add LANGUAGE C to fix find_package(Clang REQUIRED)
- error
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1,5 +1,5 @@
- cmake_minimum_required(VERSION 3.8)
--project(ccls LANGUAGES CXX)
-+project(ccls LANGUAGES CXX C)
-
- option(USE_SYSTEM_RAPIDJSON "Use system RapidJSON instead of the git submodule if exists" ON)
-
-
diff --git a/dev-util/ccls/files/ccls-0.20210330-llvm14.patch b/dev-util/ccls/files/ccls-0.20210330-llvm14.patch
deleted file mode 100644
index 79bf0f124422..000000000000
--- a/dev-util/ccls/files/ccls-0.20210330-llvm14.patch
+++ /dev/null
@@ -1,139 +0,0 @@
-https://github.com/MaskRay/ccls/commit/3ce756e39ae48204f016a58684652ad62b4dd9f9.patch
-https://github.com/MaskRay/ccls/commit/8422f0a522b6fbcb4412a8ec73d80b4acbc7e00f.patch
-https://github.com/MaskRay/ccls/commit/790daca4b2d9d5873623fee86283cd61212df674.patch
-
-From: Fangrui Song <i@maskray.me>
-Date: Thu, 23 Sep 2021 13:36:01 -0700
-Subject: [PATCH] Adaopt llvmorg-14-init-3863-g601102d282d5: refactor
- clang::isIdentifierBody
-
----
- src/clang_tu.hh | 4 ++++
- src/indexer.cc | 6 +++---
- src/working_files.cc | 9 ++++++---
- 3 files changed, 13 insertions(+), 6 deletions(-)
-
-diff --git a/src/clang_tu.hh b/src/clang_tu.hh
-index b37950926..7dbfc4a88 100644
---- a/src/clang_tu.hh
-+++ b/src/clang_tu.hh
-@@ -17,6 +17,10 @@ namespace vfs = clang::vfs;
- }
- #endif
-
-+#if LLVM_VERSION_MAJOR < 14 // llvmorg-14-init-3863-g601102d282d5
-+#define isAsciiIdentifierContinue isIdentifierBody
-+#endif
-+
- namespace ccls {
- std::string pathFromFileEntry(const clang::FileEntry &file);
-
-diff --git a/src/indexer.cc b/src/indexer.cc
-index 89d78959e..644c0ccbb 100644
---- a/src/indexer.cc
-+++ b/src/indexer.cc
-@@ -527,8 +527,8 @@ class IndexDataConsumer : public index::IndexDataConsumer {
- auto i = name.find(short_name);
- if (short_name.size())
- while (i != std::string::npos &&
-- ((i && isIdentifierBody(name[i - 1])) ||
-- isIdentifierBody(name[i + short_name.size()])))
-+ ((i && isAsciiIdentifierContinue(name[i - 1])) ||
-+ isAsciiIdentifierContinue(name[i + short_name.size()])))
- i = name.find(short_name, i + short_name.size());
- if (i == std::string::npos) {
- // e.g. operator type-parameter-1
-@@ -552,7 +552,7 @@ class IndexDataConsumer : public index::IndexDataConsumer {
- paren++;
- else if (name[i - 1] == '(')
- paren--;
-- else if (!(paren > 0 || isIdentifierBody(name[i - 1]) ||
-+ else if (!(paren > 0 || isAsciiIdentifierContinue(name[i - 1]) ||
- name[i - 1] == ':'))
- break;
- }
-diff --git a/src/working_files.cc b/src/working_files.cc
-index f80f21053..4904388be 100644
---- a/src/working_files.cc
-+++ b/src/working_files.cc
-@@ -342,7 +342,10 @@ std::optional<int> WorkingFile::getIndexPosFromBufferPos(int line, int *column,
- Position WorkingFile::getCompletionPosition(Position pos, std::string *filter) const {
- int start = getOffsetForPosition(pos, buffer_content);
- int i = start;
-- while (i > 0 && isIdentifierBody(buffer_content[i - 1]))
-+#if LLVM_VERSION_MAJOR < 14 // llvmorg-14-init-3863-g601102d282d5
-+#define isAsciiIdentifierContinue isIdentifierBody
-+#endif
-+ while (i > 0 && isAsciiIdentifierContinue(buffer_content[i - 1]))
- --i;
- *filter = buffer_content.substr(i, start - i);
- return getPositionForOffset(buffer_content, i);
-@@ -455,10 +458,10 @@ std::string_view lexIdentifierAroundPos(Position position,
- c = content[start - 1];
- if (c == ':' && start > 1 && content[start - 2] == ':')
- start--;
-- else if (!isIdentifierBody(c))
-+ else if (!isAsciiIdentifierContinue(c))
- break;
- }
-- for (; end < content.size() && isIdentifierBody(content[end]); end++)
-+ for (; end < content.size() && isAsciiIdentifierContinue(content[end]); end++)
- ;
-
- return content.substr(start, end - start);
-
-
-From: Fangrui Song <i@maskray.me>
-Date: Sun, 9 Jan 2022 12:25:07 -0800
-Subject: [PATCH] Adapt llvmorg-14-init-13600-g92417eaf3329: braced constructor
- call
-
----
- src/messages/textDocument_signatureHelp.cc | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/src/messages/textDocument_signatureHelp.cc b/src/messages/textDocument_signatureHelp.cc
-index 8e8a7277..4192272a 100644
---- a/src/messages/textDocument_signatureHelp.cc
-+++ b/src/messages/textDocument_signatureHelp.cc
-@@ -80,6 +80,10 @@ class SignatureHelpConsumer : public CodeCompleteConsumer {
- #if LLVM_VERSION_MAJOR >= 8
- ,
- SourceLocation openParLoc
-+#endif
-+#if LLVM_VERSION_MAJOR >= 14
-+ ,
-+ bool braced
- #endif
- ) override {
- ls_sighelp.activeParameter = (int)currentArg;
-@@ -93,7 +97,11 @@ class SignatureHelpConsumer : public CodeCompleteConsumer {
- cand = OverloadCandidate(pattern);
-
- const auto *ccs =
-+#if LLVM_VERSION_MAJOR >= 14
-+ cand.CreateSignatureString(currentArg, s, *alloc, cCTUInfo, true, braced);
-+#else
- cand.CreateSignatureString(currentArg, s, *alloc, cCTUInfo, true);
-+#endif
-
- const char *ret_type = nullptr;
- SignatureInformation &ls_sig = ls_sighelp.signatures.emplace_back();
-
-
-From: Fangrui Song <i@maskray.me>
-Date: Sun, 30 Jan 2022 11:17:32 -0800
-Subject: [PATCH] query: include llvm/ADT/STLExtras.h
-
-The header is no longer transitively included in 2022-01.
---- a/src/query.cc
-+++ b/src/query.cc
-@@ -9,6 +9,8 @@
-
- #include <rapidjson/document.h>
-
-+#include <llvm/ADT/STLExtras.h>
-+
- #include <assert.h>
- #include <functional>
- #include <limits.h>