summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-09 07:09:51 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-11 15:20:34 +0200
commit0967057a69d7f97894df3e3336fbf9f52ff45eea (patch)
tree5fdc0c3a7d51a916750cae061c5ad8d2e6087e20
parentdev-util/rpmdevtools: remove old (diff)
downloadgentoo-0967057a.tar.gz
gentoo-0967057a.tar.bz2
gentoo-0967057a.zip
media-libs/libkate: Use the configure var to override PYTHON
Replace the 'sed' hack with a cleaner PYTHON=: configure override to disable Python. This will make it possible to override it per-ABI.
-rw-r--r--media-libs/libkate/libkate-0.4.1-r3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/libkate/libkate-0.4.1-r3.ebuild b/media-libs/libkate/libkate-0.4.1-r3.ebuild
new file mode 100644
index 000000000000..fe9f12324925
--- /dev/null
+++ b/media-libs/libkate/libkate-0.4.1-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit ltprune python-single-r1
+
+DESCRIPTION="Codec for karaoke and text encapsulation for Ogg"
+HOMEPAGE="https://code.google.com/p/libkate/"
+SRC_URI="https://libkate.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+IUSE="debug doc wxwidgets"
+REQUIRED_USE="wxwidgets? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ media-libs/libogg:=
+ media-libs/libpng:0=
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ sys-devel/bison
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="${COMMON_DEPEND}
+ wxwidgets? (
+ ${PYTHON_DEPS}
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+ media-libs/liboggz )
+"
+
+pkg_setup() {
+ use wxwidgets && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable doc) \
+ $(usex wxwidgets '' 'PYTHON=:')
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ use wxwidgets && python_fix_shebang "${D}"
+}