summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-04-24 09:36:23 -0700
committerPatrick McLean <chutzpah@gentoo.org>2024-04-24 09:36:35 -0700
commit0971ed4265b98d738ce1f170e42f80e8de8a4764 (patch)
tree1f75b38ae2c20b851475e05375c5e0ad75efb7ae
parentdev-python/requests_download: Revbump, add py312 (bug #929506) (diff)
downloadgentoo-0971ed4265b98d738ce1f170e42f80e8de8a4764.tar.gz
gentoo-0971ed4265b98d738ce1f170e42f80e8de8a4764.tar.bz2
gentoo-0971ed4265b98d738ce1f170e42f80e8de8a4764.zip
dev-util/gcovr: add 7.2
Closes: https://bugs.gentoo.org/929537 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-util/gcovr/Manifest1
-rw-r--r--dev-util/gcovr/gcovr-7.2.ebuild209
2 files changed, 210 insertions, 0 deletions
diff --git a/dev-util/gcovr/Manifest b/dev-util/gcovr/Manifest
index 03fad14d234f..a51fbef99dc7 100644
--- a/dev-util/gcovr/Manifest
+++ b/dev-util/gcovr/Manifest
@@ -1,3 +1,4 @@
DIST gcovr-5.1.tar.gz 1676960 BLAKE2B 106c30c7e349f8ffa7a9c52d70e59c32799a8def11986027e3b794ada07fc11ab27b322c377b553f4bb96ca8662bf152eeb7de2d1913381e6068123d2430aa6c SHA512 ae2f0d9ad04f2dc851db9bc99a30a5dc1b1f43dbc6336422ecf5228d37f6994406a83e50f1ee6b5c8d6ec6d7b9e2bba726fd3d502dc5022fe359d480e6d267a5
DIST gcovr-5.2.tar.gz 1381017 BLAKE2B 8dcd7eb5d482f2020eb29da74e215f0b7731654a66b4ca6d0d919ad6b7eebe564c211a8ec5c4ef87efd61e7c18bfa524aae56d653522f23e4bb902a3921f9522 SHA512 d1a4dd63129ac1d2b9a892ced9b4a0644dc49dc3a115d81ddf348e43fea0e7809c6533104106da8f89a666a4af9ff5a62429b4270ff2272ca61bbebecb7fb921
DIST gcovr-6.0.tar.gz 1054940 BLAKE2B 1947950d06926cf48d456e6bc389db46cfe4c7ed0395da1ebdb75aa1ea4b85f3cea536d77a4ddca5621885daaaf54462160592a5a384247f12ad3ed5c299b0b7 SHA512 3b4d30417b5000d2d28bc156dc9db43ba62cf8756aa5a9619391457d0042dc8eaf1743c5defdaabffb6b423bf2fcf8172b3e6c8795419758abc1acf4853de4bb
+DIST gcovr-7.2.gh.tar.gz 2800014 BLAKE2B e334688f129868d9affe0fa5c5280eb7dd4c57825bec31f32d529c579f622e7c60985f8aad506bd714ebe00c47fd61b673ad2352e51a0fd8175777bb6a1c93e7 SHA512 fc4acbfeef48866c5c8884681375069c7308a86aaefe5b36e631240a96dcdc7c56b3e8d0c221f66dbbe29302b549c5c9b9c5e01bbf4103165b085ae33c369f55
diff --git a/dev-util/gcovr/gcovr-7.2.ebuild b/dev-util/gcovr/gcovr-7.2.ebuild
new file mode 100644
index 000000000000..aa226b32ebe5
--- /dev/null
+++ b/dev-util/gcovr/gcovr-7.2.ebuild
@@ -0,0 +1,209 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit toolchain-funcs distutils-r1
+
+DESCRIPTION="A Python script for summarizing gcov data"
+HOMEPAGE="https://github.com/gcovr/gcovr"
+SRC_URI="https://github.com/gcovr/gcovr/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/yaxmldiff[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PATH="${TEST_DIR}/scripts:${PATH}" \
+ PYTHONPATH="${TEST_DIR}/lib"
+
+ # these tests assume gcc-8, and fail with newer gcc versions
+ local -a test_build_deselect=(
+ "add_coverages-coveralls"
+ "add_coverages-html"
+ "add_coverages-html"
+ "bad++char-coveralls"
+ "bad++char-html"
+ "calls-html"
+ "cmake_oos-coveralls"
+ "cmake_oos-html"
+ "cmake_oos_ninja-coveralls"
+ "cmake_oos_ninja-html"
+ "coexisting_object_directories-from_build_dir-cobertura"
+ "coexisting_object_directories-from_build_dir-html"
+ "coexisting_object_directories-from_build_dir-without_object_dir-cobertura"
+ "coexisting_object_directories-from_build_dir-without_object_dir-html"
+ "coexisting_object_directories-from_build_dir-without_object_dir-sonarqube"
+ "coexisting_object_directories-from_build_dir-without_object_dir-txt"
+ "coexisting_object_directories-from_build_dir-without_search_dir-cobertura"
+ "coexisting_object_directories-from_build_dir-without_search_dir-html"
+ "coexisting_object_directories-from_build_dir-without_search_dir-sonarqube"
+ "coexisting_object_directories-from_build_dir-without_search_dir-txt"
+ "coexisting_object_directories-from_root_dir-cobertura"
+ "coexisting_object_directories-from_root_dir-html"
+ "coexisting_object_directories-from_root_dir-without_object_dir-cobertura"
+ "coexisting_object_directories-from_root_dir-without_object_dir-html"
+ "coexisting_object_directories-from_root_dir-without_object_dir-sonarqube"
+ "coexisting_object_directories-from_root_dir-without_object_dir-txt"
+ "coexisting_object_directories-from_root_dir-without_search_dir-cobertura"
+ "coexisting_object_directories-from_root_dir-without_search_dir-html"
+ "coexisting_object_directories-from_root_dir-without_search_dir-sonarqube"
+ "coexisting_object_directories-from_root_dir-without_search_dir-txt"
+ "config-output-html"
+ "config-toml-html"
+ "config-toml-txt"
+ "decisions-html"
+ "decisions-json"
+ "decisions-neg-delta-html"
+ "different-function-lines-separate-coveralls"
+ "different-function-lines-separate-html"
+ "different-function-lines-use-0-coveralls"
+ "different-function-lines-use-0-html"
+ "different-function-lines-use-max-coveralls"
+ "different-function-lines-use-max-html"
+ "different-function-lines-use-min-coveralls"
+ "different-function-lines-use-min-html"
+ "dot-coveralls"
+ "dot-html"
+ "excl-branch-coveralls"
+ "excl-branch-html"
+ "excl-line-branch-coveralls"
+ "excl-line-branch-html"
+ "excl-line-coveralls"
+ "excl-line-custom-coveralls"
+ "excl-line-custom-html"
+ "excl-line-html"
+ "exclude-directories-relative-coveralls"
+ "exclude-directories-relative-html"
+ "exclude-lines-by-pattern-coveralls"
+ "exclude-lines-by-pattern-html"
+ "exclude-relative-coveralls"
+ "exclude-relative-from-unfiltered-tracefile-html"
+ "exclude-relative-html"
+ "exclude-throw-branches-cobertura"
+ "exclude-throw-branches-coveralls"
+ "exclude-throw-branches-html"
+ "exclude-throw-branches-jacoco"
+ "exclude-throw-branches-json"
+ "exclude-throw-branches-lcov"
+ "exclude-throw-branches-sonarqube"
+ "exclude-throw-branches-txt"
+ "filter-absolute-coveralls"
+ "filter-absolute-from-unfiltered-tracefile-html"
+ "filter-absolute-html"
+ "filter-relative-coveralls"
+ "filter-relative-from-unfiltered-tracefile-html"
+ "filter-relative-html"
+ "filter-relative-lib-coveralls"
+ "filter-relative-lib-from-unfiltered-tracefile-html"
+ "filter-relative-lib-html"
+ "html-css-html"
+ "html-default-html"
+ "html-encoding-cp1252-html"
+ "html-encoding-iso-8859-15-html"
+ "html-high-100-html"
+ "html-high-75-html"
+ "html-line-branch-html"
+ "html-medium-100-high-100-html"
+ "html-medium-50-html"
+ "html-nested-filter-html"
+ "html-nested-nonsort-html"
+ "html-nested-sort-casefold-html"
+ "html-nested-sort-percentage-html"
+ "html-nested-sort-uncovered-html"
+ "html-source-encoding-cp1252-html"
+ "html-source-encoding-utf8-html"
+ "html-tab-size-2-html"
+ "html-template-dir-html"
+ "html-themes-github-html"
+ "html-themes-html"
+ "html-title-html"
+ "linked-coveralls"
+ "linked-html"
+ "nested-coveralls"
+ "nested-html"
+ "nested2-coveralls"
+ "nested2-coveralls"
+ "nested2-html"
+ "nested2-html"
+ "nested2-use-existing-coveralls"
+ "nested2-use-existing-html"
+ "nested3-coveralls"
+ "no-markers-html"
+ "nobranch-coveralls"
+ "nobranch-html"
+ "noncode-coveralls"
+ "noncode-html"
+ "oos-coveralls"
+ "oos-html"
+ "oos2-coveralls"
+ "oos2-html"
+ "rounding-html"
+ "shadow-coveralls"
+ "shadow-html"
+ "shared_lib-coveralls"
+ "shared_lib-html"
+ "simple1-coveralls"
+ "simple1-dir-coveralls"
+ "simple1-dir-html"
+ "simple1-html"
+ "simple1-stdout-coveralls"
+ "simple1-stdout-html"
+ "sort-percentage-html"
+ "sort-uncovered-html"
+ "source_from_pipe-cobertura"
+ "source_from_pipe-coveralls"
+ "source_from_pipe-html"
+ "source_from_pipe-lcov"
+ "subfolder-includes-html"
+ "threaded-coveralls"
+ "threaded-html"
+ "update-data-coveralls"
+ "update-data-html"
+ "use-existing-coveralls"
+ "use-existing-html"
+ "wspace-coveralls"
+ "wspace-html"
+ )
+
+ readarray -t EPYTEST_DESELECT < <(printf 'gcovr/tests/test_gcovr.py::test_build[%s]\n' "${test_build_deselect[@]}")
+
+ EPYTEST_DESELECT+=(
+ # tests that don't work in the ebuild environment
+ gcovr/tests/test_args.py::test_html_template_dir
+ gcovr/tests/test_args.py::test_multiple_output_formats_to_stdout
+ gcovr/tests/test_args.py::test_multiple_output_formats_to_stdout_1
+ )
+
+ local cc cc_ver
+ cc="$(tc-get-compiler-type)"
+ case "${cc}" in
+ gcc) cc_ver="$(gcc-major-version)";;
+ clang) cc_ver="$(clang-major-version)";;
+ # placeholder since tests need CC_REFERENCE to be string-number
+ *) cc_ver=1
+ esac
+
+ local -x CC_REFERENCE="${cc}-${cc_ver}"
+
+ epytest gcovr
+}