summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-10 12:07:40 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-10 12:07:56 +0200
commit0985a8297b958391afff2e607a2ec7240cad050a (patch)
tree5aab25983d05f20591568b746c404d3568028997
parentkde-apps/ktp-common-internals: Raise dependency on t-logger-qt (diff)
downloadgentoo-0985a829.tar.gz
gentoo-0985a829.tar.bz2
gentoo-0985a829.zip
sys-libs/glibc: Fix part of the test build system, bug 623548
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--sys-libs/glibc/glibc-2.26-r1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.26-r1.ebuild b/sys-libs/glibc/glibc-2.26-r1.ebuild
index 9876c073967f..fbe7444f9488 100644
--- a/sys-libs/glibc/glibc-2.26-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.26-r1.ebuild
@@ -280,16 +280,25 @@ glibc_do_configure() {
# Glibc does not work with gold (for various reasons) #269274.
tc-ld-disable-gold
+ # CXX isnt handled by the multilib system, so if we dont unset here
+ # we accumulate crap across abis
+ unset CXX
+
einfo "Configuring glibc for $1"
local v
- for v in ABI CBUILD CHOST CTARGET CBUILD_OPT CTARGET_OPT CC LD {AS,C,CPP,CXX,LD}FLAGS ; do
+ for v in ABI CBUILD CHOST CTARGET CBUILD_OPT CTARGET_OPT CC CXX LD {AS,C,CPP,CXX,LD}FLAGS ; do
einfo " $(printf '%15s' ${v}:) ${!v}"
done
# The glibc configure script doesn't properly use LDFLAGS all the time.
export CC="$(tc-getCC ${CTARGET}) ${LDFLAGS}"
einfo " $(printf '%15s' 'Manual CC:') ${CC}"
+
+ # Some of the tests are written in C++, so we need to force our multlib abis in, bug 623548
+ export CXX="$(tc-getCXX ${CTARGET}) $(get_abi_CFLAGS)"
+ einfo " $(printf '%15s' 'Manual CXX:') ${CXX}"
+
echo
local myconf=()