summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-10 17:30:32 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-10 17:38:59 +0100
commit098b4170f7171df2aebe283c44a375ccf191a109 (patch)
tree7ff6b196a95cf314f25cd63e5512d079e4c18dfa
parentnet-dns/coredns: Copy coredns-1.11.1-deps.tar.xz to dev space (diff)
downloadgentoo-098b4170.tar.gz
gentoo-098b4170.tar.bz2
gentoo-098b4170.zip
gnome-extra/gnome-shell-extension-bluetooth-quick-connect: add 45
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-45.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest
index df4dd13a72b6..9fbc09a82358 100644
--- a/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest
+++ b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extension-bluetooth-quick-connect-36.tar.gz 27126 BLAKE2B 0fd5e166bb1c0bcd237e4fcb741581bc0bdb7e1be4ea90ab860de64b3a04064315c08697598286eee29b07c5f4689d86e80925cd3da3f77036480fbbde7c0d62 SHA512 fa72495e4e935d7f2751d6652d2e6e337a858db56ee56374a361810dd4e8a48ded38b533b6b1e2d975f1e732579e5b054b17d953db2f50a27f2b58ff147612d9
+DIST gnome-shell-extension-bluetooth-quick-connect-45.tar.gz 25061 BLAKE2B e298dfdbc7253a34c9713c599443a35a3814c079c0b911c59664a3fedc69c330d6a5e9233bf1ca7e6150eb999ea6e6cd34a43abd5d64c47d92fbe093e88f9374 SHA512 a7c2f775ae04428d36969f59598e4f583e24ee1ed9fa35bfd339409421bbca92e0ab9cf8a9b7d29a680a4fc18aa871a393f1de0415cefceb61de6dfffc16bdda
diff --git a/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-45.ebuild b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-45.ebuild
new file mode 100644
index 000000000000..a1648910963f
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-45.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Allow to connect bluetooth paired devices from gnome control panel"
+HOMEPAGE="https://github.com/Extensions-Valhalla/gnome-bluetooth-quick-connect"
+SRC_URI="https://github.com/Extensions-Valhalla/gnome-bluetooth-quick-connect/archive/refs/tags/gnome-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ net-wireless/bluez
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-45
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/gnome-bluetooth-quick-connect-gnome-${PV}"
+extension_uuid="bluetooth-quick-connect@bjarosze.gmail.com"
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf README.md LICENSE Makefile schemas || die
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+ dosym ../../../../../usr/share/glib-2.0/schemas /usr/share/gnome-shell/extensions/"${extension_uuid}"/schemas
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}