summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-02 14:43:12 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-02 14:44:25 +0100
commit0998c53837dc3e31cd3b4b063a9fae3dad09dc65 (patch)
treef027acfbc52eb625fadef6277b0a139edab6fbc9
parentdev-python/mkdocs: add 1.4.2 (diff)
downloadgentoo-0998c538.tar.gz
gentoo-0998c538.tar.bz2
gentoo-0998c538.zip
app-text/zotero-bin: add 6.0.16
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--app-text/zotero-bin/Manifest2
-rw-r--r--app-text/zotero-bin/zotero-bin-6.0.16.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
index ac817f94e66c..e8d71ad37eb1 100644
--- a/app-text/zotero-bin/Manifest
+++ b/app-text/zotero-bin/Manifest
@@ -2,3 +2,5 @@ DIST zotero-bin-6.0.14-amd64.tar.bz2 69149210 BLAKE2B 8979e00f2bb80c97aa65fde5b2
DIST zotero-bin-6.0.14-x86.tar.bz2 70825827 BLAKE2B e4f2ed26997feac6a3214dd06fc91f5555afd583ce835a4f34bb84c659a38ed2fbdc59692a5fdf2423c7d480d0c7e6b0dbf361a462661bd9fb05955532e15a15 SHA512 3c26ce57570946c2a62eb3631fa95c0130372144ab3d2a5ba795290031f247939d25c541c6f7e9a2f31a3478e09e2196771299bce1683232a476e31836c6bb7a
DIST zotero-bin-6.0.15-amd64.tar.bz2 69160685 BLAKE2B 0e02bf2762ec89e206bb52c84ce855d00500ba8dc70d8715553eaaf70a9aa97b1b2bd1628dfee24c9c2e47ce7174be2f9b733efce2d9062f93d7f82ec4e12e8c SHA512 f1fb30a3446f9373f9f7aa1d0a21a26dc3f1bf34f0804e2aeabc617cbd2b93b471dfbaec51c41e1745e6813ead9029e5b3c5dae199760193433c51cb7316a8c9
DIST zotero-bin-6.0.15-x86.tar.bz2 70849558 BLAKE2B 1214ca4b0a06398f5f424a20320cddb7fb8b5f6815f01d05f0d92b274e991df2a6dc5005645fcf64e724229ff346928c44b59364a8de31c80f2f4d65f00a7f66 SHA512 81a994ca2932f423e13988cb3579c2e4d4e2a3aa3a21456fb351259ea8ea4467931bba12f5e5f3416f7bdebc2038dc266fa20f71eea3b62de31d0848ea975d4a
+DIST zotero-bin-6.0.16-amd64.tar.bz2 69199096 BLAKE2B 3b97576a930df2eca06b052b23c60871772ec94b9a42fd257e3b20aba3fd90aa96db656f174a9544fad737481bd5a1fca36db804207acdd7971fda67b72f9802 SHA512 e79c052ab8d94cc53cdf1fa3e0852a3984b3305768e8363f515440b20a6f0390781a16e14dc753a71493313df6f3c626832aa1a4ced9d4305a8a54a233ac4a2d
+DIST zotero-bin-6.0.16-x86.tar.bz2 70892888 BLAKE2B a2ad3f880960af100863c60da3066d5223f6e2336cefcba9ed0bf0088f15f72155bfb11b4ea0e3b7017cc77d26999d8d16d5264c310e8241fdbbccbacd6153c0 SHA512 434f447d3f754d7e7b02617b02673d0fe565a5c642537bc16ca634ed2f747fd60fe025d2e448cd63644bf671443685bf998223df5cbe875cf56d1b0f48740412
diff --git a/app-text/zotero-bin/zotero-bin-6.0.16.ebuild b/app-text/zotero-bin/zotero-bin-6.0.16.ebuild
new file mode 100644
index 000000000000..8f643569fc34
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-6.0.16.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="
+ amd64? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}-amd64.tar.bz2 )
+ x86? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-i686&version=${PV} -> ${P}-x86.tar.bz2 )
+"
+S="${WORKDIR}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ app-accessibility/at-spi2-core
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/zotero/*"
+
+src_prepare() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ # disable auto-update
+ sed -i -e 's/\(pref("app.update.enabled"\).*/\1, false);/' defaults/preferences/prefs.js || die
+
+ # disable default oo installation questions - manual installation is still possible
+ sed -i -e 's/\(pref("extensions.zoteroOpenOfficeIntegration.skipInstallation"\).*/\1, true);/' \
+ extensions/zoteroOpenOfficeIntegration@zotero.org/defaults/preferences/zoteroOpenOfficeIntegration.js || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero#' zotero.desktop || die
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop || die
+
+ default
+}
+
+src_install() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ dodir opt/zotero
+ cp -a * "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 16 32 48 256; do
+ newicon -s ${size} chrome/icons/default/default${size}.png zotero.png
+ done
+}