summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-09 22:38:58 -0500
committerDavid Seifert <soap@gentoo.org>2018-04-20 21:43:11 +0200
commit099c12fe646e1c7a6d7c44a653c988fe6aaf26c5 (patch)
treec12bf5c7f1f20629896df66be5986e12e442fca2
parentmedia-gfx/darktable: fdo-mime->xdg-utils (diff)
downloadgentoo-099c12fe646e1c7a6d7c44a653c988fe6aaf26c5.tar.gz
gentoo-099c12fe646e1c7a6d7c44a653c988fe6aaf26c5.tar.bz2
gentoo-099c12fe646e1c7a6d7c44a653c988fe6aaf26c5.zip
media-gfx/gnofract4d: fdo-mime->xdg-utils
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--media-gfx/gnofract4d/gnofract4d-3.14-r1.ebuild12
-rw-r--r--media-gfx/gnofract4d/gnofract4d-3.14.1.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/media-gfx/gnofract4d/gnofract4d-3.14-r1.ebuild b/media-gfx/gnofract4d/gnofract4d-3.14-r1.ebuild
index c6931c84c568..73a10f4e5557 100644
--- a/media-gfx/gnofract4d/gnofract4d-3.14-r1.ebuild
+++ b/media-gfx/gnofract4d/gnofract4d-3.14-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 fdo-mime
+inherit distutils-r1 xdg-utils
DESCRIPTION="A program for drawing beautiful mathematically-based images known as fractals"
HOMEPAGE="http://gnofract4d.sourceforge.net/"
@@ -30,11 +30,11 @@ src_install() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
}
diff --git a/media-gfx/gnofract4d/gnofract4d-3.14.1.ebuild b/media-gfx/gnofract4d/gnofract4d-3.14.1.ebuild
index 437acd4d8528..0b9934a1077f 100644
--- a/media-gfx/gnofract4d/gnofract4d-3.14.1.ebuild
+++ b/media-gfx/gnofract4d/gnofract4d-3.14.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=1
MY_PV=V_${PV//./_}
-inherit distutils-r1 fdo-mime
+inherit distutils-r1 xdg-utils
DESCRIPTION="A program for drawing beautiful mathematically-based images known as fractals"
HOMEPAGE="http://edyoung.github.io/gnofract4d/"
@@ -43,11 +43,11 @@ python_install_all() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
}