summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-05-07 11:39:27 +0200
committerHans de Graaff <graaff@gentoo.org>2017-05-07 11:44:29 +0200
commit09ca1504b5350d1258526828975368959e697659 (patch)
tree85c257ecb25a6d7d8fb8ca21f72933d8243bd12f
parentdev-ruby/addressable: add ruby24 (diff)
downloadgentoo-09ca1504.tar.gz
gentoo-09ca1504.tar.bz2
gentoo-09ca1504.zip
dev-ruby/heredoc_unindent: add ruby24
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
index 07749b2b9ff9..974957f05b20 100644
--- a/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
+++ b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
inherit ruby-fakegem
-RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
DESCRIPTION="Removes leading whitespace from Ruby heredocs"
HOMEPAGE="https://github.com/adrianomitre/heredoc_unindent"
@@ -17,8 +17,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="doc test"
-ruby_add_bdepend "test? ( >=dev-ruby/hoe-2.8.0 dev-ruby/test-unit:2 )
- doc? ( >=dev-ruby/hoe-2.8.0 )"
+ruby_add_bdepend "test? ( >=dev-ruby/hoe-2.8.0 dev-ruby/test-unit:2 )"
all_ruby_prepare() {
sed -i -e '1igem "test-unit"' test/test_heredoc_unindent.rb || die