summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2018-08-10 14:29:47 -0700
committerMike Frysinger <vapier@gentoo.org>2018-08-14 18:13:40 -0400
commit09caf9c6b60784ab66b3ecdf65416f6d71e3fccb (patch)
treeaa2b0258a3fe0055776fc3ae72f742d4705f93c1
parentsys-cluster/crmsh: version bump, fixes #612198 (diff)
downloadgentoo-09caf9c6.tar.gz
gentoo-09caf9c6.tar.bz2
gentoo-09caf9c6.zip
dev-util/stressapptest: version bump to 1.0.9
-rw-r--r--dev-util/stressapptest/Manifest1
-rw-r--r--dev-util/stressapptest/stressapptest-1.0.9.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/stressapptest/Manifest b/dev-util/stressapptest/Manifest
index 6d5bb5e7e8b4..ea3d4a728040 100644
--- a/dev-util/stressapptest/Manifest
+++ b/dev-util/stressapptest/Manifest
@@ -1 +1,2 @@
DIST stressapptest-1.0.8.tar.gz 218485 BLAKE2B a843330dfbf16b324a13e4156c819e8b9139288bd316d560410aeb704ff4e24c47d86dd3b1d1a65d325b86110015c6e893cd38aea99d59b7c68989ba2228f376 SHA512 b5fde353d15958052219c3e505a22aa914e03a7fe96c3a0ac5025a4c730643f6fbdd5088a7cc0dd4618d4998151e2374507845110af8f2cdb43ccd4c87d48916
+DIST stressapptest-1.0.9.tar.gz 219517 BLAKE2B 58fdb60b924bedd526cf31ed47a56cf4cca288abb43054fc6de5379ec2c6ea705c92eec1ef657274949009e40e8fa82ee9cc6e1bda2ef160a894ba95519fcfd8 SHA512 2680b9a4e148a2fe0cb7758ffde7624c8874bbae1e7650bb4df6916512be5949996da16d52f530b237fe4c6122fa9bb2d35b11092d106f59d614b44eec250595
diff --git a/dev-util/stressapptest/stressapptest-1.0.9.ebuild b/dev-util/stressapptest/stressapptest-1.0.9.ebuild
new file mode 100644
index 000000000000..27748ce9fde5
--- /dev/null
+++ b/dev-util/stressapptest/stressapptest-1.0.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic
+
+DESCRIPTION="Stressful Application Test"
+HOMEPAGE="https://github.com/stressapptest/stressapptest"
+SRC_URI="https://github.com/stressapptest/stressapptest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/libaio"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # Matches the configure & sat.cc logic.
+ use debug || append-cppflags -DNDEBUG -DCHECKOPTS
+ econf --disable-default-optimizations
+}