summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Beddek <telans@posteo.de>2022-01-22 12:26:55 +1300
committerSam James <sam@gentoo.org>2022-01-21 23:58:38 +0000
commit09ea588269f415e8a298e7354b6fd2ee0b81e443 (patch)
treedb412653c9a2456d70dc8c9df32bfa21247b4290
parentapp-text/recode: add 3.7.10 (diff)
downloadgentoo-09ea5882.tar.gz
gentoo-09ea5882.tar.bz2
gentoo-09ea5882.zip
app-admin/usbview: add 2.2
Bug: https://bugs.gentoo.org/831756 Signed-off-by: James Beddek <telans@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/23905 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-admin/usbview/Manifest1
-rw-r--r--app-admin/usbview/usbview-2.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/usbview/Manifest b/app-admin/usbview/Manifest
index 96a8cfafcba0..0c259976e3ae 100644
--- a/app-admin/usbview/Manifest
+++ b/app-admin/usbview/Manifest
@@ -1,2 +1,3 @@
DIST usbview-2.0.tar.gz 366337 BLAKE2B d3ce8f3b97ebb650f7cc8b47d7a4c4b985022811f55b43b41a65aaa120450aa187ce2dfc2671315575dfcbd108b68ca50420145a6c59ab85f7c4fcfc53a233f9 SHA512 87b3d0b0c734c94e5527f19575c0460f5c0b894dac29936a759d573058c9c007ad59c9be32a5c6d485cba258193efe4ca15bdd6f3ca31df321ed230778b5404f
DIST usbview-2.1.tar.gz 377376 BLAKE2B 76e6a45a31006f7a7b69783b608dd33304a1a3401c784bfdce62079c764795cbd4914b030ca44884f2f9dd14a479bd679be6c1eabd8bc1776a902b4d1446d82f SHA512 7d973eb9ad74e8c0842396e6239ee44d5feab2d3ce412f7c91e18b947604bcf3c2d3dc456bbefc4cd7567a03d9306593b378ce29c3fb3b13eefe75af3f4c14d4
+DIST usbview-2.2.tar.gz 378077 BLAKE2B 85edd8b4e7a36e6be4402024c4e4eb04ad28a1f402011ddb9e7a5182e8af02e3c4e01713e0d93c85d9eb61d1d70fd08b9292592975956b54eb40a37c2ad38dd1 SHA512 07684667310a9e073de05d4cb14a56370e72d4c1a2a81038331d7e0f5a546c65cb0cacedc6117702c116bb5863551f6ae730b4a9e6313d45fb052c9ce7823d16
diff --git a/app-admin/usbview/usbview-2.2.ebuild b/app-admin/usbview/usbview-2.2.ebuild
new file mode 100644
index 000000000000..217b6dadb3e2
--- /dev/null
+++ b/app-admin/usbview/usbview-2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="Display the topology of devices on the USB bus"
+HOMEPAGE="http://www.kroah.com/linux-usb/ https://github.com/gregkh/usbview"
+SRC_URI="http://www.kroah.com/linux-usb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/imagemagick-tools[png,svg]
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~DEBUG_FS"
+ linux-info_pkg_setup
+}