summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-28 12:50:43 +0100
committerSam James <sam@gentoo.org>2022-10-28 12:50:43 +0100
commit09eab4d4c13faf484c7622c51ea14ba0b53d6877 (patch)
tree74df770dacd2d11273a64ae73cbe89d7abf2f196
parentprofiles: mask =media-libs/fontconfig-2.14.1 (diff)
downloadgentoo-09eab4d4c13faf484c7622c51ea14ba0b53d6877.tar.gz
gentoo-09eab4d4c13faf484c7622c51ea14ba0b53d6877.tar.bz2
gentoo-09eab4d4c13faf484c7622c51ea14ba0b53d6877.zip
dev-python/pythran: fix installed headers for GCC 13
Closes: https://bugs.gentoo.org/878527 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pythran/files/pythran-0.12.0-gcc13.patch36
-rw-r--r--dev-python/pythran/pythran-0.12.0-r2.ebuild (renamed from dev-python/pythran/pythran-0.12.0-r1.ebuild)1
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pythran/files/pythran-0.12.0-gcc13.patch b/dev-python/pythran/files/pythran-0.12.0-gcc13.patch
new file mode 100644
index 000000000000..d7b9f28f0f45
--- /dev/null
+++ b/dev-python/pythran/files/pythran-0.12.0-gcc13.patch
@@ -0,0 +1,36 @@
+https://github.com/serge-sans-paille/pythran/pull/2029
+
+From 13a89edad477077331ae8071eadf239e88adea0c Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 28 Oct 2022 12:47:35 +0100
+Subject: [PATCH] Fix build with GCC 13 (missing <cstdint> include)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+When building scipy, one gets:
+```
+/usr/lib/python3.10/site-packages/pythran/pythonic/include/types/combined.hpp:304:17: error: ‘uint8_t’ was not declared in this scope
+ 304 | SCALAR_COMBINER(uint8_t)
+ | ^~~~~~~
+/usr/lib/python3.10/site-packages/pythran/pythonic/include/types/combined.hpp:300:21: note: in definition of macro ‘SCALAR_COMBINER’
+ 300 | struct __combined<Type, Type> { \
+ | ^~~~
+/usr/lib/python3.10/site-packages/pythran/pythonic/include/types/combined.hpp:5:1: note: ‘uint8_t’ is defined in header ‘<cstdint>’; did you forget to ‘#include <cstdint>’?
+ 4 | #include "pythonic/include/types/traits.hpp"
+ +++ |+#include <cstdint>
+```
+
+Bug: https://bugs.gentoo.org/878527
+--- a/pythran/pythonic/include/types/combined.hpp
++++ b/pythran/pythonic/include/types/combined.hpp
+@@ -1,6 +1,8 @@
+ #ifndef PYTHONIC_INCLUDE_TYPES_COMBINED_HPP
+ #define PYTHONIC_INCLUDE_TYPES_COMBINED_HPP
+
++#include <cstdint>
++
+ #include "pythonic/include/types/traits.hpp"
+ PYTHONIC_NS_BEGIN
+ namespace types
+
diff --git a/dev-python/pythran/pythran-0.12.0-r1.ebuild b/dev-python/pythran/pythran-0.12.0-r2.ebuild
index 585d64925bd1..3a8d913b453c 100644
--- a/dev-python/pythran/pythran-0.12.0-r1.ebuild
+++ b/dev-python/pythran/pythran-0.12.0-r2.ebuild
@@ -49,6 +49,7 @@ distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}"/${PN}-0.10.0-tests-werror.patch
+ "${FILESDIR}"/${PN}-0.12.0-gcc13.patch
)
src_configure() {