summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-06-27 22:43:53 +0200
committerPacho Ramos <pacho@gentoo.org>2018-06-27 22:43:53 +0200
commit09f3692cd60de6970ac77d9f12bf5425868a1080 (patch)
treeaddf091358fe445a7252036c7c75d54e76d08230
parentdev-python/chump: Support python3.6 (diff)
downloadgentoo-09f3692c.tar.gz
gentoo-09f3692c.tar.bz2
gentoo-09f3692c.zip
dev-python/cliff-tablib: Support python3.6
Package-Manager: Portage-2.3.41, Repoman-2.3.9
-rw-r--r--dev-python/cliff-tablib/cliff-tablib-1.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/cliff-tablib/cliff-tablib-1.1-r1.ebuild b/dev-python/cliff-tablib/cliff-tablib-1.1-r1.ebuild
new file mode 100644
index 000000000000..2028ca7acd51
--- /dev/null
+++ b/dev-python/cliff-tablib/cliff-tablib-1.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Formatter extensions of JSON, YAML, and HTML output for the cliff framework"
+HOMEPAGE="https://github.com/dreamhost/cliff-tablib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="dev-python/tablib[${PYTHON_USEDEP}]
+ dev-python/cliff[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ # Use IUSE examples for installing the demoapp
+ use examples && local EXAMPLES=( demoapp/. )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}