summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-05 20:28:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-05 20:28:33 +0300
commit09f725d89bbf3b38f97dfded93562a22d2b8a8e5 (patch)
treed117909a34e9defab6fd28d800e78bef209531a9
parentdev-python/prettytable: add 3.3.0 (diff)
downloadgentoo-09f725d89bbf3b38f97dfded93562a22d2b8a8e5.tar.gz
gentoo-09f725d89bbf3b38f97dfded93562a22d2b8a8e5.tar.bz2
gentoo-09f725d89bbf3b38f97dfded93562a22d2b8a8e5.zip
dev-python/oslo-concurrency: add 4.5.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-4.5.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index 45a241227279..fb6cec0090b7 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1 +1,2 @@
DIST oslo.concurrency-4.5.0.tar.gz 58979 BLAKE2B 9e2eb4a233985a33994aeaf335c195c980e1e9dd8b48a7c4e53ae502599f12c0dc65466ee45569a97b72f1face0e80ce166922ca3e42f6ad28fd5b27bdf884a3 SHA512 13a2f4d39d3241370374e6fe4ea6047dfc4d20da6116aaebd27f085fdbce089d58b0ebab4f1224234c88237cdefafc2f96229e6527bf5cda13ef1e471e25a50c
+DIST oslo.concurrency-4.5.1.tar.gz 59126 BLAKE2B 61f509b4ce76cd036b695bb5ad744374e029239a63a629a4b96d44c8ba29150095fe9d57000367c4d07dc7c358ef61cfa4868a2347f206327093ad32ffb85955 SHA512 88319915c90befb01a275666b4a760357c1e72f04d5faf27ab9c67629ecbf2dd3a73d077f3c57435231b55aa777a9642f26e91cc4cb27ad56eb801b2b98eca48
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-4.5.1.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-4.5.1.ebuild
new file mode 100644
index 000000000000..03da8577b477
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-4.5.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Oslo Concurrency library"
+HOMEPAGE="https://pypi.org/project/oslo.concurrency/
+ https://github.com/openstack/oslo.concurrency"
+SRC_URI="mirror://pypi/o/${PN/-/.}/${PN/-/.}-${PV}.tar.gz"
+S="${WORKDIR}/${PN/-/.}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/eventlet-0.19.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ )
+"
+
+distutils_enable_tests unittest
+
+python_compile() {
+ distutils-r1_python_compile
+ if ! has "${EPYTHON}" python3.{8..9}; then
+ find "${BUILD_DIR}"/install -name '*eventlet*.py' -delete || die
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}