summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-06 18:40:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-06 22:11:01 +0200
commit09fbc65f06baf4c360b139cef1a0809cd5f502b5 (patch)
tree7113acf26bcc6e07df33f31778671ae0f1fc9b35
parentprofiles/targets/systemd: add sysv-utils to BOOTSTRAP_USE (diff)
downloadgentoo-09fbc65f.tar.gz
gentoo-09fbc65f.tar.bz2
gentoo-09fbc65f.zip
dev-python/botocore: Bump to 1.27.87
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.87.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 9132bad30a57..f1d889325571 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.27.81.gh.tar.gz 9663876 BLAKE2B 35da266dee35d717c0190378d4e73dbc
DIST botocore-1.27.82.gh.tar.gz 9665050 BLAKE2B 2a108b09425dbb853a3ca79a370cff1c5c6e9fafe51c8ea9b3a7b1bf7c7ebdeccc4a5ebfc0d60e26d3bcb35add24d55e9f2df8062a79710a64f1eea4af0f258b SHA512 52335df0e487580bc425d421c39464e4785ee7018ad25c82f83ba07cce0534b4e1ea047997a3a31bc8547f597863998154b0d13b9124342129953640bf2e67c3
DIST botocore-1.27.84.gh.tar.gz 9689021 BLAKE2B 1f67ab89d0e181b3b4b8d335279efbe531dab8f22e07e1bbf323b50910ae5c4b7827494aa5b35f21474f60ff276c6d1c3554e1266791ac24289ff9c43e397755 SHA512 a80a67313cbbccd1a59a24dae42f412594fb29b4b3731bfd9fcd55b3ab1f4f6f047b38283d1a8f6e75074e3daa1d4730702e46ecc5e6befe0ffb4110344b7312
DIST botocore-1.27.86.gh.tar.gz 9702116 BLAKE2B 6df00c34c2be77c8719126cef7df3de9c6e9e618d7309a3bf9a02246f28e819d04c7fc0dacb9cbb4c6814fd869728d51e0e349d8b2d9dcce4ac4aefb4f431ad7 SHA512 dd16a3d6593a7a6ef449fd7f3b6725e1843c77d210586f212c604d2c2f49a43c5a32f973161e43abb3ef8111ea544d1b9b45b09bca2daa7be16fa3931ed79899
+DIST botocore-1.27.87.gh.tar.gz 9703217 BLAKE2B 9e512e97fa79aa49f8b414b38e0fab14ffd6cd8f89877da66b6659851c2b73ee8058faa6a2cdd8925c8a189fbd701c85ed6c00ce8ffa61ff667078ce47495a5c SHA512 ae34a63cfd3a707b7888deaa9d08a186366f53b725da80095e4cc3e5533ea07074b631923fb6eaae970e12ae39648b3f2c7cbfde03754fffe75aa57eb9c18566
diff --git a/dev-python/botocore/botocore-1.27.87.ebuild b/dev-python/botocore/botocore-1.27.87.ebuild
new file mode 100644
index 000000000000..d1a6948e70e5
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.87.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}