summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-04-04 13:57:04 +0200
committerPacho Ramos <pacho@gentoo.org>2017-04-04 14:05:09 +0200
commit0a0e6a5e0b7ed4069266f2fcee32e74b7f08b584 (patch)
treeb74ab17d368a6bc4225afdf557301d51d8f95440
parentsys-devel/heirloom-devtools: Fix gcc6 support, bug #594090 by Peter Levine, a... (diff)
downloadgentoo-0a0e6a5e.tar.gz
gentoo-0a0e6a5e.tar.bz2
gentoo-0a0e6a5e.zip
sys-apps/readahead-list: Fix gcc6 support, bug #594092 by Peter Levine, also stop using base.eclass
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc-4.3.patch4
-rw-r--r--sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc6.patch15
-rw-r--r--sys-apps/readahead-list/readahead-list-1.20060421.1016-r2.ebuild60
3 files changed, 77 insertions, 2 deletions
diff --git a/sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc-4.3.patch b/sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc-4.3.patch
index 6264bbad9525..ccee025dcbf8 100644
--- a/sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc-4.3.patch
+++ b/sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc-4.3.patch
@@ -1,5 +1,5 @@
---- src/filelist-order.cxx
-+++ src/filelist-order.cxx
+--- a/src/filelist-order.cxx
++++ b/src/filelist-order.cxx
@@ -19,6 +19,7 @@
#include <iostream>
#include <fstream>
diff --git a/sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc6.patch b/sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc6.patch
new file mode 100644
index 000000000000..a987e4aa767d
--- /dev/null
+++ b/sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc6.patch
@@ -0,0 +1,15 @@
+filelist-order.cxx:276:37: error: unable to find string literal operator ‘operator""fmt’ with ‘const char [3]’, ‘long unsigned int’ arguments
+
+https://bugs.gentoo.org/594092
+
+--- a/src/filelist-order.cxx
++++ b/src/filelist-order.cxx
+@@ -273,7 +273,7 @@ void printItem(PAIR_COMPLETE_TYPE p,vector <OrderField*> *ofa) {
+ continue;
+ }
+ OrderField of = *ofp;
+-#define case_entry(fmt,func) printf("%s"fmt,(first ? "" : " "),func_##func(mk)); break;
++#define case_entry(fmt,func) printf("%s" fmt,(first ? "" : " "),func_##func(mk)); break;
+ switch(of.type) {
+ case ST_DEV: case_entry("%lld",ST_DEV);
+ case ST_INO: case_entry("%lld",ST_INO);
diff --git a/sys-apps/readahead-list/readahead-list-1.20060421.1016-r2.ebuild b/sys-apps/readahead-list/readahead-list-1.20060421.1016-r2.ebuild
new file mode 100644
index 000000000000..80b37f7a964a
--- /dev/null
+++ b/sys-apps/readahead-list/readahead-list-1.20060421.1016-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Preloads files into the page cache to accelerate program loading"
+HOMEPAGE="http://www.orbis-terrarum.net"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/os-headers
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc-4.3.patch"
+ "${FILESDIR}/${P}-gcc6.patch"
+)
+
+src_configure() {
+ econf --sbindir=/sbin
+}
+
+src_install() {
+ default
+
+ # init scripts
+ #cd "${S}/contrib/init/gentoo/"
+ newinitd "${FILESDIR}"/init.d-readahead-list readahead-list
+ newinitd "${FILESDIR}"/init.d-readahead-list-early readahead-list-early
+ newconfd "${FILESDIR}"/conf.d-readahead-list readahead-list
+
+ # default config
+ insinto /etc/readahead-list
+ cd "${S}/contrib/data"
+ newins readahead.runlevel-default.list runlevel-default
+ newins readahead.runlevel-boot.list runlevel-boot
+ newins readahead._sbin_rc.list exec_sbin_rc
+
+ # docs
+ cd "${S}"
+ if use doc; then
+ docinto scripts
+ dodoc contrib/scripts/*
+ fi
+ # clean up a bit
+ find "${D}/usr/share/doc/${PF}/" -type f -name 'Makefile*' -exec rm -f \{\} \;
+}
+
+pkg_postinst() {
+ einfo "You should add readahead-list to your runlevels:"
+ einfo " rc-update add readahead-list-early boot"
+ einfo " rc-update add readahead-list boot"
+ einfo "Also consider customizing the lists in /etc/readahead-list"
+ einfo "for maximum performance gain."
+}