summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-18 10:41:38 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-18 10:44:58 +0100
commit0a185ef67e4e2c0cb752b27dd137204129ead4bc (patch)
treede8a4e2f8ad71a7113b9f256f71b15c89bc2142d
parentapp-text/mftrace: python-single-r1, EAPI=6 (diff)
downloadgentoo-0a185ef67e4e2c0cb752b27dd137204129ead4bc.tar.gz
gentoo-0a185ef67e4e2c0cb752b27dd137204129ead4bc.tar.bz2
gentoo-0a185ef67e4e2c0cb752b27dd137204129ead4bc.zip
app-text/queequeg: python-single-r1, EAPI=6
-rw-r--r--app-text/queequeg/queequeg-0.91-r1.ebuild (renamed from app-text/queequeg/queequeg-0.91.ebuild)43
1 files changed, 15 insertions, 28 deletions
diff --git a/app-text/queequeg/queequeg-0.91.ebuild b/app-text/queequeg/queequeg-0.91-r1.ebuild
index b89272f9f412..5fe6a7a5583b 100644
--- a/app-text/queequeg/queequeg-0.91.ebuild
+++ b/app-text/queequeg/queequeg-0.91-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="3"
-PYTHON_DEPEND="2"
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
-inherit python
+inherit python-single-r1
DESCRIPTION="A checker for English grammar, for people who are not native English"
HOMEPAGE="http://queequeg.sourceforge.net/"
@@ -19,15 +19,6 @@ IUSE=""
DEPEND="app-dicts/wordnet"
RDEPEND="${DEPEND}"
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- python_convert_shebangs -r ${PYTHON_ABI} .
-}
-
src_compile() {
local dictdir=/usr/dict
@@ -35,28 +26,24 @@ src_compile() {
dictdir=/usr/share/wordnet/dict
fi
- emake dict WORDNETDICT=${dictdir} || die
+ emake dict WORDNETDICT=${dictdir}
+
+ python_fix_shebang qq
}
src_install() {
- local prefix=$(python_get_sitedir)/${PN}
+ local prefix=/usr/lib/queequeg
- insinto ${prefix}
- doins *.py
+ python_moduleinto "${prefix}"
+ python_domodule *.py
+ insinto "${prefix}"
[[ -f "dict.txt" ]] && doins dict.txt || doins dict.cdb
- exeinto ${prefix}
+ exeinto "${prefix}"
doexe qq
- dosym ${prefix}/qq /usr/bin/qq
+ dodir /usr/bin
+ dosym ../lib/queequeg/qq /usr/bin/qq
dodoc README TODO
- dohtml htdocs/*
-}
-
-pkg_postinst() {
- python_mod_optimize queequeg
-}
-
-pkg_postrm() {
- python_mod_cleanup queequeg
+ dodoc htdocs/*
}