summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-09-09 18:23:51 -0700
committerMatt Turner <mattst88@gentoo.org>2021-09-09 18:24:59 -0700
commit0a1b1bc4a6cd1a435ac0a897809ad054c9da643e (patch)
treecf1c88dd94a5f83b069fc53adbbf52b1725d3f46
parentnet-libs/dleyna-connector-dbus: Version bump to 0.4.1 (diff)
downloadgentoo-0a1b1bc4.tar.gz
gentoo-0a1b1bc4.tar.bz2
gentoo-0a1b1bc4.zip
x11-libs/gtksourceview: Version bump to 4.8.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/gtksourceview/Manifest1
-rw-r--r--x11-libs/gtksourceview/gtksourceview-4.8.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
index d21ca1b3c8c1..e0c490536dbe 100644
--- a/x11-libs/gtksourceview/Manifest
+++ b/x11-libs/gtksourceview/Manifest
@@ -1,3 +1,4 @@
DIST gtksourceview-2.10.5.tar.bz2 1253321 BLAKE2B 810a3eeca69bab4356b21c64129bb852e00d02c7937ad4a2ce3af9e48700da943d8d6834efcce9810dd49a54f39d4a074dc086a557128da51a593b2f23e58d48 SHA512 6f64acef6196bfc5953e0b148d7e460d366073b5e21367c01b01fc4d1c86ffe8aca71ecd77cf0814e47d8fc3085495f25bbbdc69e746987b02fd02fcda64886d
DIST gtksourceview-3.24.11.tar.xz 1438232 BLAKE2B a25762255a12887c8151465689e3acbd5864a6638044500acd087832888a092b8aad5d885d31c9dbe057ce183510afa2342bccb2a2675719dbba7e82be72368a SHA512 3490b34c6432a2e2ef292ad5bf982fdd22d33b1472434549b4ea8ddae0fc8808e128ef947e4d0dcb41e8de5e601b202f52532bbbbfa11d35050acfc42f9936b2
DIST gtksourceview-4.8.1.tar.xz 1160032 BLAKE2B 3ed93f056ca8c6ae1982e28a675ccec448c301999f058abc5b9ec46f609c2649ac807fc20379480a8eb00408496912e1554e08d55ce5da70a97cee34be10fc20 SHA512 fe3bc05e81f881b97a53e6dfb807ded314f1953ebe74424b515d6c1333e72011e3b756b958cca40becad0f66434cf16c56d42fff950b8d643e65c9a03e9cb88b
+DIST gtksourceview-4.8.2.tar.xz 1164876 BLAKE2B 3e6269b4e6a7147d5f4e0ed2096514a0e0bc29a928b73c0cd12eb207f2627c9eadde55ee81183b2a67fe5380fcd96c2335283a1f3da3f06303b7d2b65b49a09a SHA512 6951b9477b1e47b1b25756aef246630c948e8dd212b1b0e13f87ef4f56f39b59b02db3fd18315869e98acfc6454de13cfffa6eeb8fe1cd030dfd537b5f710a04
diff --git a/x11-libs/gtksourceview/gtksourceview-4.8.2.ebuild b/x11-libs/gtksourceview/gtksourceview-4.8.2.ebuild
new file mode 100644
index 000000000000..bf81d9a8aeba
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-4.8.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson vala virtualx xdg
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="LGPL-2.1+"
+SLOT="4"
+
+IUSE="glade gtk-doc +introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.48:2
+ >=x11-libs/gtk+-3.24:3[introspection?]
+ >=dev-libs/libxml2-2.6:2
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ >=dev-libs/fribidi-0.19.7
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.25
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use glade glade_catalog)
+ -Dinstall_tests=false
+ $(meson_use introspection gir)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/${PN}-4/language-specs
+ newins "${FILESDIR}"/4.6-gentoo.lang gentoo.lang
+
+ # Avoid conflict with gtksourceview:3.0 glade-catalog
+ # TODO: glade doesn't actually show multiple GtkSourceView widget collections, so with both installed, can't really be sure which ones are used
+ if use glade; then
+ mv "${ED}"/usr/share/glade/catalogs/gtksourceview.xml "${ED}"/usr/share/glade/catalogs/gtksourceview-${SLOT}.xml || die
+ fi
+}