summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-10-29 18:55:15 -0400
committerMike Gilbert <floppym@gentoo.org>2016-10-29 18:56:00 -0400
commit0a2c3b7d818710bc02be94f1e144fda1ae1c02c9 (patch)
treeb3eac2594f4bda42714f42c9034b4e651551265c
parentsci-mathematics/cvc3: Add a patch to fix compiling with GCC 6 (diff)
downloadgentoo-0a2c3b7d.tar.gz
gentoo-0a2c3b7d.tar.bz2
gentoo-0a2c3b7d.zip
sys-apps/systemd: install rootlib_LTLIBRARIES on non-native abis
Bug: https://bugs.gentoo.org/598216 Package-Manager: portage-2.3.2
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 05e3fe58e2c6..c0a9abccef1b 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -279,7 +279,7 @@ multilib_src_compile() {
else
echo 'gentoo: $(BUILT_SOURCES)' | \
emake "${mymakeopts[@]}" -f Makefile -f - gentoo
- echo 'gentoo: $(lib_LTLIBRARIES) $(pkgconfiglib_DATA)' | \
+ echo 'gentoo: $(lib_LTLIBRARIES) $(rootlib_LTLIBRARIES) $(pkgconfiglib_DATA)' | \
emake "${mymakeopts[@]}" -f Makefile -f - gentoo
fi
}
@@ -305,6 +305,7 @@ multilib_src_install() {
else
mymakeopts+=(
install-libLTLIBRARIES
+ install-rootlibLTLIBRARIES
install-pkgconfiglibDATA
install-includeHEADERS
# safe to call unconditionally, 'installs' empty list