summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-14 21:42:38 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-14 21:53:22 +0100
commit0a4333cc5a0d1df7b8af95ef318ea42946337ba2 (patch)
tree72e04a39ab489735caac6cd955dad74867b6c585
parentdev-python/weasyprint: Bump to 53.4 (diff)
downloadgentoo-0a4333cc.tar.gz
gentoo-0a4333cc.tar.bz2
gentoo-0a4333cc.zip
dev-python/moto: Bump to 2.2.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-2.2.15.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index c469bf4065ca..5d70009c1654 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -1,3 +1,4 @@
DIST moto-2.0.5.tar.gz 1551415 BLAKE2B 452cb94443188e1715145bee574f04924d894a3d647673443a8a335bb907f8601098540b032d6c9a8ced3e1fc490c49ad70c877547d905cece05bbb742d05976 SHA512 70e64ab98873d480e776a2139a4d351665c6c2f98faf90e2871c6b9998571d1bd239757bc90bbc6ab6e1ed510598bfce77157ad522953efe40c884068885c57d
DIST moto-2.2.12.tar.gz 1941427 BLAKE2B d1f85e46f4072b0e1c48e727d9e99eec12001a5397e738a5ab2e776c59e273a887c72dc5e5fdf2e6b61028f4eddb4b6fa809288bf7b087502192139eae170127 SHA512 a55e96bfe1f1c4a4523be30040350fc2929fb4385a62cc5a96a8fb34febed54d442be0e169f836f813e956c9e388fce8b9c405c59ad023011f9c7c76362c3729
DIST moto-2.2.14.tar.gz 1962233 BLAKE2B 2e61a2a946bdb51280fc16a2efd47e88e9643a04cebec1fc117a984b3bb8be366523fb202fe558137c4bf5c6a9e8b2e035adceda6fd37712b004d650d3d042fd SHA512 2f6c5a498f95760e910174c91562aa4f5a223d691efc1db65b66508c407641473b5b94512e67f48ed02e3733421cc51eba7aa569b19e92cf58ffa6bbcb81b362
+DIST moto-2.2.15.tar.gz 1962356 BLAKE2B 469f9c0eb36552b475b5e76fe286a6e50ae6379a9b0436a40eb290fd033123b2b400b6b85a1dd66b01176f1795a0211831acf10efac1a44a09f17efe325fad3b SHA512 2fffb3d095cd7274891d1d9ff5eee07550773eb06d1410205db39c75234e37833bda12aca7c29fda5b1d415145e55e7c7d59f8a03f3163c8f752e968fc273d3a
diff --git a/dev-python/moto/moto-2.2.15.ebuild b/dev-python/moto/moto-2.2.15.ebuild
new file mode 100644
index 000000000000..7c4b8e8a3d1b
--- /dev/null
+++ b/dev-python/moto/moto-2.2.15.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-tempfile[${PYTHON_USEDEP}]' python3_{6,7})
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/cfn-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.9.201[${PYTHON_USEDEP}]
+ >=dev-python/botocore-1.12.201[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # unpin indirect dep on ecdsa that's supposed to workaround pip bugs
+ sed -i -e '/ecdsa/s:<0.15::' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network'
+}