summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-20 04:32:05 +0100
committerSam James <sam@gentoo.org>2022-10-20 04:43:03 +0100
commit0a5b8af6d6b24d4794fc626971972e1714a52365 (patch)
treed84609fdd2952fd2895d7c6cc508bd15befe637a
parentapp-emacs/treemacs: install missing python scripts (diff)
downloadgentoo-0a5b8af6d6b24d4794fc626971972e1714a52365.tar.gz
gentoo-0a5b8af6d6b24d4794fc626971972e1714a52365.tar.bz2
gentoo-0a5b8af6d6b24d4794fc626971972e1714a52365.zip
sys-apps/texinfo: add 6.8.90 ("pretest", unkeyworded)
Bug: https://bugs.gentoo.org/574740 Bug: https://bugs.gentoo.org/624394 Bug: https://bugs.gentoo.org/679238 Bug: https://bugs.gentoo.org/863713 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/texinfo/Manifest1
-rw-r--r--sys-apps/texinfo/texinfo-6.8.90.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/texinfo/Manifest b/sys-apps/texinfo/Manifest
index 50f5aeda97ed..ee6947ac5ffd 100644
--- a/sys-apps/texinfo/Manifest
+++ b/sys-apps/texinfo/Manifest
@@ -1 +1,2 @@
+DIST texinfo-6.8.90.tar.xz 6324912 BLAKE2B 106dfa2c415cfd40c54befa3b431f5b07eb5561af5f46083d00cac58e74f24c72d955f7796a393687a94703348cb66012d10e9264d23f5995d8dad070eaa55ff SHA512 afcdba96aecbc480ff8a9955d6e86f7c5e95ee8c09a88c483246ef8d90d42665b8823f2a34aad08aa68a498d8ae97bca5cae07e0c4cbe6f2bd5f72ed039c8da6
DIST texinfo-6.8.tar.xz 4961528 BLAKE2B 0256dac5ba9c7f171c970644907b763f7a88fd9995111244df0458591aed1a0fe94c76045dde69f9138d65d6f780aae6869bbbc013f58e04ae7c62456b222bbb SHA512 0ff9290b14e4d83e32b889cfa24e6d065f98b2a764daf6b92c6c895fddbb35258398da6257c113220d5a4d886f7b54b09c4b117ca5eacfee6797f9bffde0f909
diff --git a/sys-apps/texinfo/texinfo-6.8.90.ebuild b/sys-apps/texinfo/texinfo-6.8.90.ebuild
new file mode 100644
index 000000000000..9013b3c925b7
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-6.8.90.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: if your package uses the texi2dvi utility, it must depend on the
+# virtual/texi2dvi package to pull in all the right deps. The tool is not
+# usable out-of-the-box because it requires the large tex packages.
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="https://www.gnu.org/software/texinfo/"
+
+if [[ $(ver_cut 3) -ge 90 ]] ; then
+ SRC_URI="https://alpha.gnu.org/gnu/${PN}/${P}.tar.xz"
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="nls +standalone static"
+
+RDEPEND="
+ !=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2:=
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ standalone? ( >=dev-lang/perl-5.8.1 )
+ !standalone? ( >=dev-lang/perl-5.8.1:= )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( >=sys-devel/gettext-0.19.6 )"
+
+src_prepare() {
+ default
+
+ if use prefix ; then
+ sed -i -e '1c\#!/usr/bin/env sh' util/texi2dvi util/texi2pdf || die
+ touch doc/{texi2dvi,texi2pdf,pdftexi2dvi}.1
+ fi
+}
+
+src_configure() {
+ # Respect compiler and CPPFLAGS/CFLAGS/LDFLAGS for Perl extensions
+ # bug #622576
+ local -x PERL_EXT_CC="$(tc-getCC)" PERL_EXT_CPPFLAGS="${CPPFLAGS}"
+ local -x PERL_EXT_CFLAGS="${CFLAGS}" PERL_EXT_LDFLAGS="${LDFLAGS}"
+
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ --cache-file="${S}"/config.cache
+ $(use_enable nls)
+ $(use_enable !standalone perl-xs)
+ )
+
+ econf "${myeconfargs[@]}"
+}