summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-03 11:35:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-03 12:20:00 +0200
commit0a5c527fd7bf322afc3cd8e4438bef865d2e8fc1 (patch)
tree22a28ab24fa23ce453c61082c85f159c578e08f1
parentdev-python/matplotlib: Bump to 3.5.2 (diff)
downloadgentoo-0a5c527f.tar.gz
gentoo-0a5c527f.tar.bz2
gentoo-0a5c527f.zip
dev-python/matplotlib: Run pytest directly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/matplotlib/matplotlib-3.5.2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.5.2.ebuild b/dev-python/matplotlib/matplotlib-3.5.2.ebuild
index b34037d20297..0aea928dc2d7 100644
--- a/dev-python/matplotlib/matplotlib-3.5.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.5.2.ebuild
@@ -260,6 +260,13 @@ src_test() {
}
python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by -Wdefault
+ "tests/test_rcparams.py::test_validator_invalid[validate_strlist-arg6-MatplotlibDeprecationWarning]"
+ "tests/test_rcparams.py::test_validator_invalid[validate_strlist-arg7-MatplotlibDeprecationWarning]"
+ tests/test_testing.py::test_warn_to_fail
+ )
+
# we need to rebuild mpl against bundled freetype, otherwise
# over 1000 tests will fail because of mismatched font rendering
grep -v system_freetype "${BUILD_DIR}"/setup.cfg \
@@ -269,7 +276,9 @@ python_test() {
distutils-r1_python_compile -j1 --build-lib="${BUILD_DIR}"/test-lib
local -x PYTHONPATH=${BUILD_DIR}/test-lib:${PYTHONPATH}
- "${EPYTHON}" -c "import sys, matplotlib as m; sys.exit(m.test(argv=['-m', 'not network'], verbosity=2))" || die
+ # speed tests up
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest --pyargs matplotlib -m "not network" || die
}
python_install() {