summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-03-06 15:17:56 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-03-06 15:17:56 +0100
commit0a5fb27219da5afba330f560338c3f77cbc13487 (patch)
treea3e2a17d62f12b4b5cc98bcb3f6bc7ffb01eef50
parentsci-physics/espresso: Fix whitespace and drop CVS header (diff)
downloadgentoo-0a5fb27219da5afba330f560338c3f77cbc13487.tar.gz
gentoo-0a5fb27219da5afba330f560338c3f77cbc13487.tar.bz2
gentoo-0a5fb27219da5afba330f560338c3f77cbc13487.zip
dev-libs/liblogging: Bump to v1.0.6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-libs/liblogging/Manifest1
-rw-r--r--dev-libs/liblogging/liblogging-1.0.6.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/liblogging/Manifest b/dev-libs/liblogging/Manifest
index cff46e645850..33a206f42212 100644
--- a/dev-libs/liblogging/Manifest
+++ b/dev-libs/liblogging/Manifest
@@ -1 +1,2 @@
DIST liblogging-1.0.5.tar.gz 571051 SHA256 310dc1691279b7a669d383581fe4b0babdc7bf75c9b54a24e51e60428624890b SHA512 fd0c89b670bdf4d257d6a31b18b44940ba2edae84633ead6577f164e1ded93709445c35027a28f6e7fda4c984964c3446978eaf0abf843e31ecc11b979e2adde WHIRLPOOL 17c22802e9037aee69c6985a627b6eb24281311292543bc4d9e0383290f7181bcf959de07405a5783f09e8d3dcfb2c88ae5701cec97a3812815f40c6a36ea715
+DIST liblogging-1.0.6.tar.gz 593393 SHA256 338c6174e5c8652eaa34f956be3451f7491a4416ab489aef63151f802b00bf93 SHA512 09c90a93b2d32afa44be5a800705a64690810a56d21bed1455cb70680b01fecd4efef3881a43f98ebcafa996b6046ed8e5af935eacc12014f330a7fd23674964 WHIRLPOOL b268028ee750276a67c176888eab0f1a621eabbeb787f962ba9405c12cbeacce99870ae37e810dce971f0a64b6c696e0b4cfc013bffd11deabfaa3f0f2ff6db9
diff --git a/dev-libs/liblogging/liblogging-1.0.6.ebuild b/dev-libs/liblogging/liblogging-1.0.6.ebuild
new file mode 100644
index 000000000000..6b46fb8ced11
--- /dev/null
+++ b/dev-libs/liblogging/liblogging-1.0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Liblogging is an easy to use, portable, open source library for system logging"
+HOMEPAGE="http://www.liblogging.org"
+SRC_URI="http://download.rsyslog.com/liblogging/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+IUSE="rfc3195 static-libs +stdlog systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable rfc3195)
+ $(use_enable stdlog)
+ $(use_enable systemd journal)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}