summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-27 23:51:17 +0000
committerSam James <sam@gentoo.org>2022-12-28 00:32:12 +0000
commit0a76df521dd7b668607ba7f366b853cd01adfc20 (patch)
tree2b02d8b5bfeca33fb7989fa37374817e3476043c
parentacct-group.eclass: Don't modify groups when EPREFIX is non-empty (diff)
downloadgentoo-0a76df521dd7b668607ba7f366b853cd01adfc20.tar.gz
gentoo-0a76df521dd7b668607ba7f366b853cd01adfc20.tar.bz2
gentoo-0a76df521dd7b668607ba7f366b853cd01adfc20.zip
app-alternatives/awk: drop 1, 3
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-alternatives/awk/awk-1.ebuild19
-rw-r--r--app-alternatives/awk/awk-3.ebuild77
2 files changed, 0 insertions, 96 deletions
diff --git a/app-alternatives/awk/awk-1.ebuild b/app-alternatives/awk/awk-1.ebuild
deleted file mode 100644
index cef6aea276d2..000000000000
--- a/app-alternatives/awk/awk-1.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Virtual for awk implementation"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-LICENSE="metapackage"
-
-RDEPEND="
- || (
- >=sys-apps/gawk-4.0.1-r1
- sys-apps/mawk
- sys-apps/nawk
- sys-apps/busybox
- )"
diff --git a/app-alternatives/awk/awk-3.ebuild b/app-alternatives/awk/awk-3.ebuild
deleted file mode 100644
index 46ba60100171..000000000000
--- a/app-alternatives/awk/awk-3.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ALTERNATIVES=(
- gawk:sys-apps/gawk
- busybox:sys-apps/busybox
- mawk:sys-apps/mawk
- nawk:sys-apps/nawk
-)
-
-inherit app-alternatives
-
-DESCRIPTION="/bin/awk and /usr/bin/awk symlinks"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="split-usr"
-
-RDEPEND="
- !app-eselect/eselect-awk
-"
-
-src_install() {
- local alt=$(get_alternative)
- local root_prefix=
- use split-usr && root_prefix=../../bin/
-
- # We could consider setting AWK=... like we do for yacc & lex,
- # but it would need some testing with a fair amount of packages first,
- # as autoconf prefers gawk.
- case ${alt} in
- busybox)
- dosym "${root_prefix}busybox" /usr/bin/awk
- ;;
- *)
- dosym "${alt}" /usr/bin/awk
- ;;
- esac
-
- newman - awk.1 <<<".so ${alt}.1"
-
- if use split-usr; then
- dosym ../usr/bin/awk /bin/awk
- fi
-}
-
-pkg_preinst() {
- local v
- for v in ${REPLACING_VERSIONS}; do
- # if we are upgrading from a new enough version, leftover manpage
- # symlink cleanup was done already
- if ver_test "${v}" -ge 3; then
- return
- fi
- done
-
- # otherwise, remove leftover files/symlinks created by eselect-awk (sic!)
- shopt -s nullglob
- local files=( "${EROOT}"/usr/share/man/man1/awk.1* )
- shopt -u nullglob
-
- if [[ ${files[@]} ]]; then
- einfo "Cleaning up leftover manpage symlinks from eselect-awk ..."
- rm -v "${files[@]}" || die
- fi
-}
-
-pkg_postrm() {
- # make sure we don't leave the user without the symlinks, since
- # they've not been owned by any other package
- if [[ ! -h ${EROOT}/usr/bin/awk ]]; then
- ln -s gawk "${EROOT}/usr/bin/awk" || die
- fi
- if [[ ! -h ${EROOT}/bin/awk ]]; then
- ln -s ../usr/bin/awk "${EROOT}/bin/awk" || die
- fi
-}