summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-03 00:55:26 +0100
committerMarek Szuba <marecki@gentoo.org>2020-12-03 00:57:24 +0100
commit0a7b9937e6b01e7173cf8f78142c64352e5165af (patch)
treeba181f4fe5dbf3880eb26f0ab83c7a2cabd060b5
parentdev-lua/luaposix: remove dev-lua/lua-bit32 from DEPEND (diff)
downloadgentoo-0a7b9937.tar.gz
gentoo-0a7b9937.tar.bz2
gentoo-0a7b9937.zip
dev-lua/luaposix: migrate to lua.eclass
Nice and easy, upstream build scripts work very nicely with the wrapper. Closes: https://bugs.gentoo.org/752930 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-lua/luaposix/luaposix-35.0-r100.ebuild70
-rw-r--r--profiles/package.mask1
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-lua/luaposix/luaposix-35.0-r100.ebuild b/dev-lua/luaposix/luaposix-35.0-r100.ebuild
new file mode 100644
index 000000000000..7881ac5e4801
--- /dev/null
+++ b/dev-lua/luaposix/luaposix-35.0-r100.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Bindings for POSIX APIs"
+HOMEPAGE="https://luaposix.github.io/luaposix/ https://github.com/luaposix/luaposix"
+SRC_URI="https://github.com/luaposix/luaposix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Requires specl, which is not in the tree yet
+RESTRICT="test"
+
+DEPEND="${LUA_DEPS}"
+RDEPEND="${DEPEND}
+ lua_targets_lua5-1? ( dev-lua/lua-bit32[lua_targets_lua5-1(-)] )
+ lua_targets_luajit? ( dev-lua/lua-bit32[lua_targets_luajit(-)] )"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Temporary fix for respect LDFLAGS (#739050)
+ # Fixed in luke 0.2.1
+ sed -i -e "s:c_module,libdirs:c_module,'\$LDFLAGS',libdirs:g" \
+ build-aux/luke || die
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ ./build-aux/luke package="${PN}" version="${PV}" \
+ PREFIX="${ED}/usr" \
+ INST_LIBDIR="${ED}/$(lua_get_cmod_dir)" \
+ INST_LUADIR="${ED}/$(lua_get_lmod_dir)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" || die
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ ./build-aux/luke install \
+ PREFIX="${ED}/usr" \
+ INST_LIBDIR="${ED}/$(lua_get_cmod_dir)" \
+ INST_LUADIR="${ED}/$(lua_get_lmod_dir)" \
+ || die
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+ dodoc -r doc NEWS.md README.md
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index cba2bad8489a..509c90833691 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -557,6 +557,7 @@ dev-lua/luacrypto
>=dev-lua/lualdap-1.2.5-r100
>=dev-lua/luajson-1.3.4
>=dev-lua/luaossl-20200709-r100
+>=dev-lua/luaposix-35.0-r100
>=dev-lua/luarocks-3.4.0-r100
>=dev-lua/luasec-0.9-r100
>=dev-lua/luasocket-3.0_rc1_p20200328-r100