summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-03 21:19:47 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-03 21:20:08 +0100
commit0a7cfad2fba3ebd240c56e67a79476720fc5fbb9 (patch)
tree3b49ca60bd27e4942d187f557dca144881401ef3
parentapp-misc/ca-certificates: Another revbump to get rid of outdated certs patch. (diff)
downloadgentoo-0a7cfad2.tar.gz
gentoo-0a7cfad2.tar.bz2
gentoo-0a7cfad2.zip
x11-misc/xosview: Bump to version 1.19
Package-Manager: portage-2.3.2
-rw-r--r--x11-misc/xosview/Manifest1
-rw-r--r--x11-misc/xosview/xosview-1.19.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/xosview/Manifest b/x11-misc/xosview/Manifest
index 5850a43dda1e..4e96de7d37d5 100644
--- a/x11-misc/xosview/Manifest
+++ b/x11-misc/xosview/Manifest
@@ -1,2 +1,3 @@
DIST xosview-1.17.tar.gz 143263 SHA256 640998e7bd23b875e2556a97b9149a4cca0ac255889f484489b13a888c19b3f1 SHA512 c1d34887aa75afd244d9b5399c00642e68e75f8b0aafc06555955200e13bca398080dfcc92421f72b0242dcfac1e41d05bfb031e49f1560196a8f6e33ce79df6 WHIRLPOOL 28530451395cfd2b971cfb1f62b21bc3a1cb08f1792f3be87cfb91b7735102cc5bc5b7d5c12f787674ce926a1bc143905db243187cc0ef7beaaa1d0354c05349
DIST xosview-1.18.tar.gz 143565 SHA256 833c8a865b6a21d4edf0ed34c78e8586954615e68dab619b079f8691fadb74fa SHA512 7ce441a24ec301fcfad251c75291a8759f42a0a3c7face4681e2e2f935a827ae3d0ba15f275151846cb4004654895a3571e89911d6846c01d8c0f81159efdab6 WHIRLPOOL ee6f9ccc95d982b64d6d96f8f90ad1596015b3d9d1c7803231cfbdf29da4f29b71137b365a74ffa9431c09c9b805c5a3bd7bb72bcf5d314b01879327741d4972
+DIST xosview-1.19.tar.gz 143151 SHA256 08b6a9e6c1963c03ba9dcb31981b9e0e93d5d1d9959cadec86be1b09e2b22caf SHA512 57234a232617b14925e21864334f2d06dce442d552763835b1a505863dd80efc27d3d55d50692de4a548e86e25bb5ab3354bd92801b6504c030e1985f19b6a08 WHIRLPOOL 6796305fe1c78beed977758e54a0df17ed5e82f13cd5499a0f7ac8bc8f9ad8da6dc96534f406b919e92a747889a3650e97c559288a2efcd288a81602387d9e15
diff --git a/x11-misc/xosview/xosview-1.19.ebuild b/x11-misc/xosview/xosview-1.19.ebuild
new file mode 100644
index 000000000000..676a2076c75e
--- /dev/null
+++ b/x11-misc/xosview/xosview-1.19.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="X11 operating system viewer"
+HOMEPAGE="http://www.pogo.org.uk/~mark/xosview/"
+SRC_URI="http://www.pogo.org.uk/~mark/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="suid"
+
+COMMON_DEPS="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt"
+RDEPEND="${COMMON_DEPS}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPS}
+ x11-proto/xproto"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:lib/X11/app:share/X11/app:g' -i ${PN}.1 || die
+ sed -i -e "s:Git:${PV}:g" ${PN}.cc || die
+ tc-export CXX
+}
+
+src_compile() {
+ emake OPTFLAGS=''
+}
+
+src_install() {
+ dobin ${PN}
+ use suid && fperms 4755 /usr/bin/${PN}
+ insinto /usr/share/X11/app-defaults
+ newins Xdefaults XOsview
+ doman *.1
+ dodoc CHANGES README.linux TODO
+}
+
+pkg_postinst() {
+ if ! use suid ; then
+ ewarn "If you want to use serial meters ${PN} needs to be executed as root."
+ ewarn "Please see ${EPREFIX}/usr/share/doc/${PF}/README.linux for details."
+ fi
+}