summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJérôme Carretero <cJ-gentoo@zougloub.eu>2023-02-17 14:07:08 -0500
committerMichał Górny <mgorny@gentoo.org>2023-02-19 20:46:20 +0100
commit0a8b9367a2cdcf49814e4d8c48efbe0196d56f2b (patch)
tree129f7efbccd4a12a2a4d3d473de202653d6c45dc
parentdev-python/cppy: add pypy3 to PYTHON_COMPAT (diff)
downloadgentoo-0a8b9367.tar.gz
gentoo-0a8b9367.tar.bz2
gentoo-0a8b9367.zip
dev-python/kiwisolver: add pypy3 to PYTHON_COMPAT
Signed-off-by: Jérôme Carretero <cJ-gentoo@zougloub.eu> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/kiwisolver/files/kiwisolver-1.4.4-pypy3-tests.patch30
-rw-r--r--dev-python/kiwisolver/kiwisolver-1.4.4-r1.ebuild44
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/kiwisolver/files/kiwisolver-1.4.4-pypy3-tests.patch b/dev-python/kiwisolver/files/kiwisolver-1.4.4-pypy3-tests.patch
new file mode 100644
index 000000000000..705855f02f61
--- /dev/null
+++ b/dev-python/kiwisolver/files/kiwisolver-1.4.4-pypy3-tests.patch
@@ -0,0 +1,30 @@
+Patch provided upstream as https://github.com/nucleic/kiwi/pull/158
+from issue created at https://github.com/nucleic/kiwi/issues/157
+
+commit ad1c62f046dc14c1e85e4e1c1b8e175eda08838e
+Author: Jérôme Carretero <cJ-kiwisolver@zougloub.eu>
+Date: Fri Feb 17 18:40:45 2023 -0500
+
+ py: tests: make tests run under PyPy
+
+diff --git a/py/tests/test_expression.py b/py/tests/test_expression.py
+index 671dd7f..6b5d8e5 100644
+--- a/py/tests/test_expression.py
++++ b/py/tests/test_expression.py
+@@ -8,6 +8,7 @@
+ import gc
+ import math
+ import operator
++import sys
+ from typing import Tuple
+
+ import pytest
+@@ -264,4 +265,7 @@ def test_expression_rich_compare_operations(op, symbol) -> None:
+ else:
+ with pytest.raises(TypeError) as excinfo:
+ op(e1, e2)
+- assert "kiwisolver.Expression" in excinfo.exconly()
++ if "PyPy" in sys.version:
++ assert "Expression" in excinfo.exconly()
++ else:
++ assert "kiwisolver.Expression" in excinfo.exconly()
diff --git a/dev-python/kiwisolver/kiwisolver-1.4.4-r1.ebuild b/dev-python/kiwisolver/kiwisolver-1.4.4-r1.ebuild
new file mode 100644
index 000000000000..67d18ec3f1e7
--- /dev/null
+++ b/dev-python/kiwisolver/kiwisolver-1.4.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=kiwi-${PV}
+DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
+HOMEPAGE="
+ https://github.com/nucleic/kiwi/
+ https://pypi.org/project/kiwisolver/
+"
+SRC_URI="
+ https://github.com/nucleic/kiwi/archive/${PV}.tar.gz -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Clear-BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-python/cppy-1.2.0[${PYTHON_USEDEP}]
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+"
+BDEPEND="
+ ${COMMON_DEPEND}
+ >=dev-python/setuptools_scm-3.4.3[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.4-pypy3-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}