summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-01 00:03:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-01 02:03:37 +0200
commit0a8fcc1500ebb674f3f6eca10b60f75c5567966f (patch)
treea64106d1b1cdfa38ef8e2880aeb6c871d2453074
parentmedia-gfx/openmesh: Use https (diff)
downloadgentoo-0a8fcc15.tar.gz
gentoo-0a8fcc15.tar.bz2
gentoo-0a8fcc15.zip
media-gfx/openmesh: src_configure cleanup
Package-Manager: Portage-2.3.41, Repoman-2.3.9
-rw-r--r--media-gfx/openmesh/openmesh-4.1.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/media-gfx/openmesh/openmesh-4.1.ebuild b/media-gfx/openmesh/openmesh-4.1.ebuild
index 22fbdb4d2926..33cb49ca2bb9 100644
--- a/media-gfx/openmesh/openmesh-4.1.ebuild
+++ b/media-gfx/openmesh/openmesh-4.1.ebuild
@@ -44,17 +44,13 @@ src_prepare() {
}
src_configure() {
- mycmakeargs=""
-
- mycmakeargs="${mycmakeargs} -DOPENMESH_BUILD_UNIT_TESTS=TRUE"
-
- # Disable python bindings until someone wants them.
- mycmakeargs="${mycmakeargs} -DOPENMESH_BUILD_PYTHON_BINDINGS=FALSE"
- mycmakeargs="${mycmakeargs} -DOPENMESH_BUILD_PYTHON_UNIT_TESTS=FALSE"
-
- if ! use qt5; then
- mycmakeargs="${mycmakeargs} -DBUILD_APPS=OFF"
- fi
+ local mycmakeargs=(
+ -DOPENMESH_BUILD_UNIT_TESTS=TRUE
+ # Disable python bindings until someone wants them.
+ -DOPENMESH_BUILD_PYTHON_BINDINGS=FALSE
+ -DOPENMESH_BUILD_PYTHON_UNIT_TESTS=FALSE
+ -DBUILD_APPS=$(usex qt5)
+ )
cmake-utils_src_configure
}